If you don't feel like reading, i will ask the question first, then explain the problem afterwards if you so choose to read it.


i'm trying to install the ndiswrapper for my Linksys WMP54G v2 ethernet card. When I modprobe ndiswrapper, this message comes up in dmesg:
ndiswrapper: version magic '2.6.9-gentoo-r1 SMP preempt PENTIUM4 gcc-3.3' should be '2.6.9-gentoo-r1 SMP preempt PENTIUM4 4KSTACKS gcc-3.3

How do I fix this? Any clues will help. I don't mind doing some reading, but I just don't know where to look.

Notice how the first one does not say 4KSTACKS. I have tried using the --force-vermagic flag. But it spits out "cannot unlink <something> "GLOBAL"" 3 times. After that, i try "modprobe ndiswrapper" again. This time it puts some promising looking messages in dmesg and doesn't complain. Either that or it Seg Faults on me. If it doesn't seg fault there, when I run iwconfig it almost certainly will then. I have managed to run iwconfig once without it seg faulting, but my card still didn't work and i haven't been able to run iwconfig since.

by the way, I have recompiled and installed the kernel using 8KSTACKS and compiled ndiswrapper with the same compiler.