Find the answer to your Linux question:
Results 1 to 4 of 4
I know, ya'll are getting sick of this newbie. I'm sorry! :P Anyway -- I have a wireless WEP problem (if that wasn't apparent). I have been playing with it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    11

    WEP in Mandrake 10.1 - Please help!!


    I know, ya'll are getting sick of this newbie. I'm sorry! :P
    Anyway -- I have a wireless WEP problem (if that wasn't apparent).

    I have been playing with it for a couple days now and have not gotten it to work. It doesn’t seem to matter if I am using 128 bit or 64 bit – it just doesn’t work. The wireless will work though if WEP is turned off. Here is the current setup:

    The laptop that I am using this on is: Compaq Presario X1000 w/ Centrino technology. With a dual boot – Mandrake 10.1 & WinXP Pro.
    Linksys wireless router – BEFW11S4 – version 4.
    Firmware: 1.50.14, May 27 2004
    MAC Address: 00-0C-41-4E-62-E7

    I am Running 64 bit WEP. I have chosen to run Key #3. The key that is being used is: 4C5ADC0180.

    In /etc/sysconfig/network-scripts The ifcfg-eth2 file is my wireless file.
    That file contains the following:

    DEVICE=eth2
    BOOTPRONTO=dhcp
    ONBOOT=yes
    HWADDR=00:04:23:5c:0e:7c
    METRIC=10
    MII_NOT_SUPPORTED=no
    WIRELESS_MODE=Managed
    Wireless_ESSID=Twanza
    WIRELESS_ENC_KEY=”restricted 4C5ADC0180”
    NEEDHOSTNAME=no
    WIRELESS_CHANNEL=6
    WIRELESS_RATE=11M

    HOWEVER

    If I go and do a iwconfig command this is what is displayed:

    Eth2 IEEE 802.11b ESSID:”Twanza” Nickname:”Tony2”
    Mode:Managed Channel:11 Access Point: 00:09:5B:C9:21:28
    Bit Rate=1MB/s Tx=Power=32 dBm
    Retry:on RTS thr=2304 B Fragment thr:off
    Power Management:off
    Link Quality:0 Signal level:0 Noise Level:158
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:- Missed beacon:27

    NOW just to make things fun.
    If I turn off encryption on the router and go through the mandrake hardware configuration, delete the encryption key, and tell it to restart the network service (I don’t know how to restart the network service any other way) it gets on the net just fine and has the following iwconfig:

    Eth2 IEEE 802.11b ESSID:”Twanza” Nickname:”Tony2”
    Mode:Managed Channel:11 Access Point: 00:09:5B:C9:21:28
    Bit Rate=11Mb/s Tx=Power=32 dBm
    Retry:on Rts thr=2304 B Fragmement Thr:off
    Power Management:Off
    Link Quality: 45/100 Signal level:-38 dBm Noise level: -98 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rxinvalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed Beacon: 45


    <….FYI – I have twice now added DHCP_TIMEOUT to both ifcfg-eth0 and ifcfg-eth2 files. When I reboot- it first skips through the eth0 connection very fast (following my timeout setting). It gets to eth2 takes a long time (I’m guessing its trying to find the network and so the dhcp timeout isn’t yet applicable) – then after that on any other reboot/shutdown & restart – the timeout lines in both files are gone and it then waits forever to try and bring up both adapters --- may be related??? Wasn’t sure – wanted to be thorough.>


    With all that info, is someone able to help me get encryption to work???

    Thanks!!!!

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    I've had a LOT of trouble getting online wirelessly, but after bashing my head against the wall for a while, I think I've got it working.

    In your iwconfig output file I don't see any entry for the encryption key, and it appears (from what you're saying) that this is the only problem.

    At a command line try,
    Code:
    ifdown eth2
    iwconfig key 4C5ADC0180 restricted
    ifup eth2
    Most of the time, this worked for me. If this doesn't work, then post the output to "ifup eth2", and maybe someone can help.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    11
    I tried the command but it didn't work (I got an error).
    Here's what happened.

    iwconfig eth2 enc 4C5ADC0180 restricted

    it came back with an error:
    Error for wireless request "Set Encode" (8B2a) :
    SET failed on device eth2: Operation not supported.

    I then tried the command without the restricted command at the end and I got the exact same error.

    ...What does this mean?

    ~Anthony

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    It might mean that you adapter is not configurable through "iwconfig" command. Could you issue command "iwpriv" and let us know what the printout is from that command.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •