Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I am quite experienced with unix and networking yet i have been working on this for a while now with no success. What im trying to do is setup a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    9

    Simple IPX Packet Routing


    I am quite experienced with unix and networking yet i have been working on this for a while now with no success. What im trying to do is setup a PPTP server with IPX support for some older lan games.

    I setup a poptop PPTP server on a redhat 9 box, Installed IPX support into my kernel, and recompiled pppd with ipx support as well. When I connect thrue pptp everything seems to work fine. The WindowsXP box talks to the redhat box and visa versa. My lan computers talk to the redhat box as well. The problem lies with somwhere with the routing. I installed ipxripd at first like i was told and it didnt work. i then installed mars-nwe and it seemed like more packets were being sent between the pptp server and clients but still no packets being sent from ppp0 to eth1. Is this just a newer kernel problem? I have an old copy of redhat 7.1 im thinking about installing but I would rather not. Also if anyone has a setup like this working already, what o.s. did you use? Any suggestions would be appricaited.

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    If you snoop your ppp0 adapter, do you get any kind of IPX traffic?
    I mean, there is no use for the IPX to speak unless there is anyone speaking with it. The clients that connects to the ppp0 adapter, do they speak IPX over their PPP connection?

    One way to trouble-shoot is to enable file-sharing over IPX, this will more or less simulate (not completly, but good enough) a NW fileserver, and then you shall get some SAP and RIP packets over your ppp0 adapter when you have a link-up

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    RIP/SAP Packets are properly being transfered between the PPTP server and client. They are also being transmitted between my lan computers and the router on eth1. Also when I start the lan games on both computers, packets are recieved by the router on both ppp0 and eth1 but they are not transmitted across interfaces. I have TCP/IP setup as well and when i enable it on the pptp client everything works on that protocol perfect. I belive the problem lies somewhere with the kernel not properly routing the IPX packets.

  4. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Ok! Then at least we got something to work with, it's been a while since I had to do some work with IPX, however, just to make sure, did you setup an IPX_INTERNAL_NET_NUM? This is very much essential if you are to route IPX packets. That's easiest done by command "ipx_internal_net" which must differ from all other IPX networks, and make sure that you have defined ipx_net on each interface as well. It is a router, and not a client, so the IPX stack will not guess or assumpt what network number is in use.

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    I did setup an internal net using the ipx_internal_net command. I also compiled my kernel with "Full IPX Internal Network" enabled. My /proc/net/ipx_route file shows that there are 3 devices directly connected... the internal network, eth1, and the network created by pppd.

  6. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    here is my ipx_interface file

    [root@earth psycho]# cat /proc/net/ipx_interface
    Network Node_Address Primary Device Frame_Type
    110000AA 000000000002 Yes Internal None
    00000003 006097B008B6 No eth1 EtherII
    00000004 00000AECE676 No ppp0 EtherII


    and here is my ipx_route

    [root@earth psycho]# cat /proc/net/ipx_route
    Network Router_Net Router_Node
    922333C3 00000004 02EE040688A7
    00000004 Directly Connected
    01721101 00000003 000039E458EA
    00000003 Directly Connected
    110000AA Directly Connected

  7. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    ok i made progress but still no result.

    i did away with the internal network and packets are being transfered from eth1 to ppp0.

    here is a read out of tcpdump on ppp0...
    15:23:07.633247 1721102.00:00:00:00:00:01.455 > 4.ff:ff:ff:ff:ff:ff.455: ipx-netbios 50
    15:23:07.699907 1721101.00:00:00:00:00:01.553 > 4.ff:ff:ff:ff:ff:ff.553: ipx-nwlink-dgm 204
    15:23:07.700503 1721101.00:00:00:00:00:01.553 > 4.ff:ff:ff:ff:ff:ff.553: ipx-nwlink-dgm 204
    15:23:23.221332 4.00:00:17:80:05:d8.453 > 4.ff:ff:ff:ff:ff:ff.453:ipx-rip-resp 24252674/2.3 24252673/2.3 3/1.1
    15:23:37.702640 1721101.00:00:00:00:00:01.553 > 4.ff:ff:ff:ff:ff:ff.553: ipx-nwlink-dgm 204
    15:23:37.704401 1721101.00:00:00:00:00:01.553 > 4.ff:ff:ff:ff:ff:ff.553: ipx-nwlink-dgm 204


    now the problem lies with the packets that the game passes getting dropped...

    here is a tcpdump output for eth1, this is the packet not getting transfered while all others do.
    15:25:57.241354 1721102.00:00:00:00:00:01.1388 > 0.ff:ff:ff:ff:ff:ff.1388: ipx-#1388 148


    any suggestions?

  8. #8
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    ok now i definitly narrowed the problem down a bit. it seems only netbios and native IPX packets such as the ones novel products use are being forwarded across interfaces. netbios and nwlink packets are for sure making it across. everything else is not getting routed across the interfaces however. perhaps this is a security issue with the newer kernels or something? im about to just downgrade to redhat 7.1 to see if this will fix the problem.

  9. #9
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Could be something to do with the frame-types that you have enabled in your kernel that halts some of the packets, if I where you I would check that out first of all, and make sure that the clients also use the same frame-types as you have defined. As far as I can recall, Ethernet_II was an implementation from Novell to handle IP as well as standard IPX, it might be so that your friends have Ethernet_802 frame-types. Check that ou as well.

  10. #10
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    i think these are broadcast packets that are not making it across the router. is there any way to allow ipx broadcast packets to be forwarded across interfaces

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •