Find the answer to your Linux question:
Results 1 to 2 of 2
i want to install db berkeley and squidguard when i want to install SquidGuard and i enter this command afte installing Db Berkeley : ./configure --with-db=/usr/local/BerkeleyDB.3.3 then i see : ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8

    SquidGuard Error ......


    i want to install db berkeley and squidguard
    when i want to install SquidGuard and i enter this command afte installing Db Berkeley :

    ./configure --with-db=/usr/local/BerkeleyDB.3.3

    then i see :


    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for executable suffix...
    checking for object suffix... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking how to run the C preprocessor... gcc -E
    checking whether make sets ${MAKE}... yes
    checking for a BSD compatible install... /usr/bin/install -c
    checking for bison... bison -y
    checking for flex... flex
    checking for yywrap in -lfl... yes
    checking lex output file root... lex.yy
    checking whether yytext is a pointer... yes
    checking for lynx... false
    checking for perl... /usr/bin/perl
    checking for db_version in -ldb... no

    ** The Berkley DB library is required for squidGuard
    to compile. Get it from http://www.sleepycat.com
    use --with-db=DIR or --with-db-lib=DIR to specify
    its location. (default is /usr/local/BerkeleyDB)

    [root@ZH79 squidGuard-1.2.0]#




    i don't know why this latest parageraph is happend?

    ** The Berkley DB library is required for squidGuard
    to compile. Get it from http://www.sleepycat.com
    use --with-db=DIR or --with-db-lib=DIR to specify
    its location. (default is /usr/local/BerkeleyDB)

    afte this when enter make command i see this error

    make: *** No targets specified and no makefile found. Stop.
    [root@ZH79 BerkeleyDB.3.3]#

    why?
    please help me
    i am confused

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    squidGuard compile errors

    Hi,

    when I had this problem I used this configure command:

    (from the /usr/local/src/squidGuard/build_unix dir)
    #../dist/configure --prefix=/usr/local/squidGuard --with-db-lib=/usr/local/BerkleyDB

    I also make the LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/BerkleyDB and this seemed to fix it.

    ta, sm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •