I have Knoppix 3.6 running on 2 laptops. My PCMCIA Linksys WPC11 ver. 3 works fine on one laptop, but won't connect to the WAP on the VAIO PCG-C1VN picture book. An lsmod shows the orinoco module loads, but I can't connect with a static IP or DHCP. Please see my log output and config files pasted below. If anyone can help, I would really appreciate it!

Thanks,

Chris




------------------ begin dmesg output:------------------------------------

Linux version 2.4.27 (root@Koffer) (gcc version 2.95.4 20011002 (Debian prerelease)) #2 SMP Mo Aug 9 00:39:37 CEST 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009b800 (usable)
BIOS-e820: 000000000009b800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000aff0000 (usable)
BIOS-e820: 000000000aff0000 - 000000000afff800 (ACPI data)
BIOS-e820: 000000000afff800 - 000000000b000000 (ACPI NVS)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
175MB LOWMEM available.
On node 0 totalpages: 45040
zone(0): 4096 pages.
zone(1): 40944 pages.
zone(2): 0 pages.
Sony Vaio laptop detected.
ACPI: RSDP (v000 SONY ) @ 0x000f8070
ACPI: RSDT (v001 SONY P1 0x20010926 PTL 0x00000000) @ 0x0affcfbe
ACPI: FADT (v002 SONY P1 0x20010926 PTL 0x000f4240) @ 0x0afff754
ACPI: BOOT (v001 SONY P1 0x20010926 PTL 0x00000001) @ 0x0afff7d8
ACPI: DSDT (v001 SONY P1 0x20010926 MSFT 0x0100000b) @ 0x00000000
Kernel command line: auto BOOT_IMAGE=Linux ro root=302 ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet desktop=xfce
No local APIC present or hardware disabled
Initializing CPU#0
Detected 595.508 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1150.15 BogoMIPS
Memory: 171648k/180160k available (1406k kernel code, 8108k reserved, 574k data, 144k init, 0k highmem)
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (32 bytes/line)
CPU: L2 Cache: 512K (128 bytes/line)
CPU: Processor revision 1.3.1.2, 600 MHz
CPU: Code Morphing Software revision 4.1.4-7-51
CPU: 20000805 23:30 official release 4.1.4#2
CPU: After generic, caps: 0080813f 0081813f 00000006 00000000
CPU: Common caps: 0080813f 0081813f 00000006 00000000
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: none
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (32 bytes/line)
CPU: L2 Cache: 512K (128 bytes/line)
CPU: Processor revision 1.3.1.2, 600 MHz
CPU: Code Morphing Software revision 4.1.4-7-51
CPU: 20000805 23:30 official release 4.1.4#2
CPU: After generic, caps: 0080813f 0081813f 00000006 00000000
CPU: Common caps: 0080813f 0081813f 00000006 00000000
CPU0: Transmeta(tm) Crusoe(tm) Processor TM5600 stepping 03
per-CPU timeslice cutoff: 1462.71 usecs.
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
Waiting on wait_init_idle (map = 0x0)
All processors have done init_idle
ACPI: Subsystem revision 20040326
PCI: PCI BIOS revision 2.10 entry at 0xfd98e, last bus=0
PCI: Using configuration type 1
ACPI: IRQ9 SCI: Level Trigger.
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: System [ACPI] (supports S0 S3 S4 S5)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: Embedded Controller [EC0] (gpe 9)
ACPI: PCI Interrupt Link [LNKA] (IRQs *9)
ACPI: PCI Interrupt Link [LNKB] (IRQs 9) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 9) *0, disabled.
ACPI: PCI Interrupt Link [LNKD] (IRQs *9)
ACPI: Power Resource [LRP0] (off)
PCI: Probing PCI hardware
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 9
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 9
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 9
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 9
PCI: Using ACPI for IRQ routing
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
pty: 256 Unix98 ptys configured
floppy0: no floppy controllers found
RAMDISK driver initialized: 16 RAM disks of 100000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 00:07.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdcio, hddio
hda: HITACHI_DK23AA-12, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 23579136 sectors (12073 MB) w/512KiB Cache, CHS=1467/255/63
Partition check:
hda: hda1 hda2
ide: late registration of driver.
SCSI subsystem driver Revision: 1.00
libata version 1.02 loaded.
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 3387k freed
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 144k freed
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
blk: queue c03661a0, I/O limit 4095Mb (mask 0xffffffff)
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), internal journal
Real Time Clock Driver v1.10f
Adding Swap: 361420k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), internal journal
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
ACPI: AC Adapter [ACAD] (on-line)
ACPI: Battery Slot [BAT1] (battery present)
ACPI: Lid Switch [LID]
ACPI: Power Button (CM) [PWRB]
ACPI: Fan [LRA0] (off)
ACPI: Processor [CPU0] (supports C1 C2 C3)
ACPI: Thermal Zone [ATF0] (48 C)
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
Yenta ISA IRQ mask 0x0cb8, PCI irq 9
Socket status: 30000006
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0820-0x08ff: clean.
cs: IO port probe 0x0800-0x080f: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x170-0x177 0x370-0x377 0x4d0-0x4d7
cs: IO port probe 0x1000-0x17ff: excluding 0x10c0-0x10c7
cs: IO port probe 0x0a00-0x0aff: clean.
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 00:50:50 Aug 9 2004
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0x1020, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usbdevfs: remount parameter error
ohci1394: $Rev: 1045 $ Ben Collins <bcollins@debian.org>
PCI: Enabling device 00:08.0 (0010 -> 0012)
ohci1394_0: OHCI-1394 1.0 (PCI): IRQ=[9] MMIO=[fc104000-fc1047ff] Max Packet=[2048]
hub.c: new USB device 00:07.2-1, assigned address 2
usb.c: USB device 2 (vend/prod 0x5dc/0xa400) is not claimed by any active driver.
ieee1394: Host added: ID:BUS[0-00:1023] GUID[0800460300b41051]
hub.c: new USB device 00:07.2-2, assigned address 3
usb.c: USB device 3 (vend/prod 0x54c/0x32) is not claimed by any active driver.
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: LEXAR Model: JUMPDRIVE PRO Rev: 1000
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 506880 512-byte hdwr sectors (260 MB)
sda: Write Protect is off
sda: sda1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
scsi2 : SCSI emulation for USB Mass Storage devices
Vendor: Sony Model: MSC-U01 Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sdb at scsi2, channel 0, id 0, lun 0
usb-uhci.c: interrupt, status 2, frame# 98
sdb: Unit Not Ready, sense:
Current 00:00: sns = 70 2
ASC=3a ASCQ= 0
Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x3a 0x00 0x00 0x00 0x00 0x00
sdb : READ CAPACITY failed.
sdb : status = 1, message = 00, host = 0, driver = 08
Current sd00:00: sns = 70 2
ASC=3a ASCQ= 0
Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x3a 0x00 0x00 0x00 0x00 0x00
sdb : block size assumed to be 512 bytes, disk size 1GB.
sdb: I/O error: dev 08:10, sector 0
I/O error: dev 08:10, sector 0
unable to read partition table
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
USB Mass Storage support registered.
sbp2: $Rev: 1074 $ Ben Collins <bcollins@debian.org>
ieee1394: sbp2: Driver forced to serialize I/O (serialize_io = 1)
Serial driver version 5.05c (2001-07-0 with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
sonypi: Sony Programmable I/O Controller Driver v1.22.
sonypi: detected type1 model, verbose = 0, fnkeyinit = off, camera = off, compat = off, mask = 0xffffffff, useinput = on
sonypi: enabled at irq=11, port1=0x10c0, port2=0x10c4
sonypi: device allocated minor is 63
Sony VAIO Jog Dial installed at input event device #0.
Linux video capture interface: v1.00
meye: using 2 buffers with 600k (1200k total) for capture
PCI: Enabling device 00:0b.0 (0010 -> 0012)
meye: Motion Eye Camera Driver v1.9.
meye: mchip KL5A72002 rev. 1, base fc104800, irq 9
PCI: Enabling device 00:09.0 (0006 -> 0007)
ymfpci: YMF754 at 0xfc108000 IRQ 9
ac97_codec: AC97 Audio codec, id: AKM2 (Asahi Kasei AK4543)
usb-uhci.c: interrupt, status 2, frame# 276
sdb: Unit Not Ready, sense:
Current 00:00: sns = 70 2
ASC=3a ASCQ= 0
Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x3a 0x00 0x00 0x00 0x00 0x00
sdb : READ CAPACITY failed.
sdb : status = 1, message = 00, host = 0, driver = 08
Current sd00:00: sns = 70 2
ASC=3a ASCQ= 0
Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x3a 0x00 0x00 0x00 0x00 0x00
sdb : block size assumed to be 512 bytes, disk size 1GB.
sdb: test WP failed, assume Write Enabled
sdb: I/O error: dev 08:10, sector 0
I/O error: dev 08:10, sector 0
unable to read partition table
Device not ready. Make sure there is a disc in the drive.
I/O error: dev 08:10, sector 0
Device not ready. Make sure there is a disc in the drive.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0820-0x08ff: clean.
cs: IO port probe 0x0800-0x080f: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x170-0x177 0x370-0x377 0x4d0-0x4d7
cs: IO port probe 0x1000-0x17ff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
lp: driver loaded but no devices found
cs: memory probe 0xa0000000-0xa0ffffff: clean.
ttyS00 at port 0x03f8 (irq = 3) is a 16550A
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
ttyS00 unloaded
Serial driver version 5.05c (2001-07-0 with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at port 0x03f8 (irq = 3) is a 16550A
ttyS00 unloaded
orinoco 0.15rc2STA (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
orinoco_cs 0.15rc2STA (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
eth0: Hardware identity 801b:0000:0001:0000
eth0: Station identity 001f:0004:0001:0003
eth0: Firmware determined as Intersil 1.3.4
eth0: Ad-hoc demo mode supported
eth0: IEEE standard IBSS ad-hoc mode supported
eth0: WEP supported, 104-bit key
eth0: MAC address 00:06:25:AA:14:47
eth0: Station name "Prism I"
eth0: ready
eth0: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
chrisup@vaio:~$

------------------ end dmesg output -------------------------------------

------------------ begin kernel log output:------------------------------

May 8 12:37:52 vaio cardmgr[643]: socket 0: Instant Wireless PC Card
May 8 12:37:53 vaio cardmgr[643]: executing: 'modprobe hermes'
May 8 12:37:53 vaio cardmgr[643]: executing: 'modprobe orinoco'
May 8 12:37:53 vaio cardmgr[643]: executing: 'modprobe orinoco_cs'
May 8 12:37:53 vaio cardmgr[643]: executing: './network start eth0'
May 8 12:37:54 vaio cardmgr[643]: + iwconfig eth0 essid "#RESTRICTED#"
May 8 12:37:54 vaio cardmgr[643]: + Sample private network setup
May 8 12:37:54 vaio cardmgr[643]: + /sbin/ifconfig eth0 up
May 8 12:37:54 vaio cardmgr[643]: + /sbin/pump -i eth0 > /dev/null
May 8 12:37:54 vaio pumpd[6130]: starting at (uptime 0 days, 10:11:39) Sun May 8 12:37:54 2005
May 8 12:37:54 vaio pumpd[6130]: PUMP: sending discover
May 8 12:38:14 vaio cardmgr[643]: + Operation failed.
May 8 12:38:14 vaio cardmgr[643]: start cmd exited with status 1
chrisup@vaio:~$

---------------------- end kernel log output ------------------------------


---------------------- begin iwconfig output ------------------------------



eth0 IEEE 802.11b ESSID:"#RESTRICTED#" Nickname:"vaio"
Mode:Managed Frequency:2.437GHz Access Point: 44:44:44:44:44:44
Bit Rate:11Mb/s Sensitivity:1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/92 Signal level=-68 dBm Noise level=-122 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:0 Missed beacon:0


---------------------- end iwconfig:-----------------------------------------

------------------- begin /etc/pcmcia/config.opts --------------------------

# Dell Notebooks freeze if something between 0x810-0x81f is included!
include port 0x100-0x4ff, port 0x800-0x80f, port 0x820-0x8ff, port 0xc00-0xcff
include memory 0xc0000-0xfffff
include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff

# High port numbers do not always work...
include port 0x1000-0x17ff

# Extra port range for IBM Token Ring

include port 0xa00-0xaff

# Resources we should not use, even if they appear to be available

# First built-in serial port
#RBC
#exclude irq 4
# Second built-in serial port
#exclude irq 3
# First built-in parallel port (if used by parport_pc)
#exclude irq 7
# PS/2 mouse
exclude irq 12
include irq 4
include irq 7
include irq 3
include irq 5
exclude irq 9


--------------------- end /etc/pcmcia/config.opts -----------------------

--------------------- begin /etc/default/pcmcia -------------------------

# Defaults for pcmcia (sourced by /etc/init.d/pcmcia)
PCMCIA=yes
PCIC=yenta_socket
PCIC_OPTS=
CORE_OPTS=
CARDMGR_OPTS=

--------------------- end /etc/default/pcmcia ---------------------------