Find the answer to your Linux question:
Results 1 to 7 of 7
i'm using a wusb54g linksys usb wireless card, with fedora core3 and ndiswrapper. i can see the networks fine with iwlist scanning , when i try to connect to a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6

    wireless connecting problem


    i'm using a wusb54g linksys usb wireless card, with fedora core3 and ndiswrapper. i can see the networks fine with iwlist scanning , when i try to connect to a network i was just connected to in windows with a good signal i just get this.


    [root@localhost ~]# dhclient wlan0
    Internet Systems Consortium DHCP Client V3.0.1
    Copyright 2004 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/products/DHCP

    sit0: unknown hardware address type 776
    sit0: unknown hardware address type 776
    Listening on LPF/wlan0/00:35:22:92:8d:3b
    Sending on LPF/wlan0/00:35:22:92:8d:3b
    Sending on Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.



    i tried tried to connect through the graphical interface too but that didn't work either. i set the right essid with iwconfig wlan0 essid. since i can scan for networks does that mean ndiswrapper and my drivers are working correctly? any suggestions?

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    6

    dhcp

    tried a static ipaddress?

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    no why would i need a static ip when any network i use with the linksys windows software automatically assigns me one? i'll try anyway, as i don't know what else to do.

  4. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    i tried setting a static ip via the graphical network config, this time i was actually able to activate it without getting a connection error, (the graphical network config said it was active) but i still am not actually connected to the internet.

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    6

    wireless

    tail -f /var/log/messages (in a console) to see whats happening

  6. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    okay when i do that apparently it is still doing dhcpdiscover and failing even though i set a static address, and the graphical interface still shows an active wlan0.


    could this be a problem
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    but my sub mask on windows shows 255.255.255.0 , i even tried setting it that way in netconfig and the graph interface but dhcpdiscover still shows that.




    what about this when i ifup
    [root@localhost ~]# ifup wlan0
    /etc/sysconfig/network-scripts/ifup-aliases: line 120: 255.255.255.255: commandnot found



    what about this when i set an essid
    [root@localhost ~]# iwconfig wlan0 ESSID "Britespot"
    when i type iwconfig it still shows ESSID:off/any
    how do i confirm what essid i set?



    could my card just be not powerful enough because of driver incompatibilities under linux, i saw another post of someone complaining their card was only 10-20 percent as powerful under linux. should i try another linux distro?

  7. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    well i finally got connected using the graph interface, i noticed it was set to Auto, once i put it to managed it connected fine, i was sure i tried that before. i'm still wondering why my mode, essid, etc can't be set with iwconfig, could it be a conflict with the graph interface?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •