Find the answer to your Linux question:
Results 1 to 3 of 3
Hi people, Ive got a RTL8139 card, and on startup i am loading the 8139too module. The thing i dont understand is where abouts the network settings are saved.. If ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    15

    Saving network settings


    Hi people,

    Ive got a RTL8139 card, and on startup i am loading the 8139too module. The thing i dont understand is where abouts the network settings are saved..

    If i run netconfig and try to ping my router i get "Network is unreachable"

    So to set things up i use the following:

    Code:
    /sbin/ifconfig -a eth0 192.168.1.4 netmask 255.255.255.0
    /sbin/route add default gw 192.168.1.1
    Once i have done that i can ping my router and its fine.. what am i doing wrong that the settings are not saved or something??

    Thanks

  2. #2
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    What are the default settings the card is given?
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    15
    Ok, umm.. complete linux noob here , so im not sure how i can find out the default settings..

    I dont know whats happening, but if i go
    Code:
    ifconfig
    when i first startup the machine, i only get the local loopback, once i run
    Code:
    netconfig
    and do ifconfig again it now shows the ethernet card as well.. i still however cant ping my router untill i use the commands that i stated in the previous post..

    Why would i need to rune netconfig to get my ethernet card to show up??

    Any ideas??

    Thanks

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •