Find the answer to your Linux question:
Results 1 to 4 of 4
I'm trying to set up my unstable Debian laptop for Wireless networking. I have ndiswrapper set up and working. I can use wireless as long as I turn off the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    Wireless won't work with WEP


    I'm trying to set up my unstable Debian laptop for Wireless networking. I have ndiswrapper set up and working. I can use wireless as long as I turn off the encryption. The problem is, when I set the WEP on the router, I can't get Linux to do anything with it.

    I use iwconfig wlan0 key MYKEY to set the key. Running iwconfig reports that the key is being used. But when I run ifup wlan0, it keeps trying to do DHCP, but to no avail.

    Another thing I don't understand is that when I set the WEP on the router, iwconfig no longer lets me change the essid. It goes to "off/any", and stays like that.

    I am using kernel 2.6.10. Any help would be appreciated.

    Thanks.

  2. #2
    Linux Newbie
    Join Date
    Mar 2005
    Location
    California!
    Posts
    159
    fedora comes with a gui that you can set the ssid and wep key. in there it tells me to input the wep key like this: 0xWEPKEYHERE . maybe its the same for you?
    Registered Linux User # 392752

    \"pr0n\": An anagram of \"porn,\" possibly indicating the use of pornography.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    Fixed it

    Thanks for the idea, but I don't have Fedora.

    I figured it out, though. I ended up setting it to open instead of restricted. Don't know why it worked, but it did.

  4. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    It's because that Restricted relies on WPA as well, not just the WEP key.
    So if you have not implemented WPA you should always set your Wireless to Open Network.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •