Find the answer to your Linux question:
Results 1 to 7 of 7
Hi I'm using Mandrake 10.1 on KDE 3.2 I just set up a (wireless) network using samba 3.0.10 (between mine an another computer) and I can see my computer and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    12

    Can see computers on network but no files


    Hi I'm using Mandrake 10.1 on KDE 3.2
    I just set up a (wireless) network using samba 3.0.10 (between mine an another computer) and I can see my computer and the other one on the network, but when I share a directory and then go into my computer under the network, there is nothing there. Also when the other computer (MAC OS) shares files I also can't see them. Samba recognises the other computer and mine but I just can't seem to get any further.
    Any help appreciated, thanks
    -Luke

  2. #2
    Just Joined! srerucha's Avatar
    Join Date
    Jun 2005
    Location
    Brno, Czech republic
    Posts
    58
    Do you have correctly set user privileges for this files ? The files sholud be readable for user that try to acces them - the logged-in user or the guest user (according to " guest account" directive).

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    12
    The folders I've tried to share have been in my home folder, so yes I have access to them as the local user. The sharing worked the first time, for a little while, but on the next reboot it had disappeared, I have tried altering smb.conf to add say:
    Code:
    [share1]
    path = /home/lucaspewkas/mp3
    but it still doesn't show up. I don't think I have a guest account set up, or at least I don't know of having set one up, just root and lucaspewkas (my account name).
    Sorry, i'm a bit of a noob but this seems like one of those things that'll be obvious once I solve it
    -Luke

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! srerucha's Avatar
    Join Date
    Jun 2005
    Location
    Brno, Czech republic
    Posts
    58
    And do you log-in (provide some username/passwd) on samba or are you acessing it anonymously ?

    Try either

    #cd /home/lucaspewkas/mp3
    #chmod chmod a+r *

    or set in your smb.conf

    guest account = lucaspewkas

    in global config

    guest ok = yes under [share1]

  6. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    12
    Thanks it's all working now.
    Don't really understand some of the settings in smb.conf though. I would like my files to be accessed without having to type a password if possible, I have set public = yes under [share1] but it still asks for a password, how do I achieve this?
    Thanks again for the help
    -Luke

  7. #6
    Just Joined! srerucha's Avatar
    Join Date
    Jun 2005
    Location
    Brno, Czech republic
    Posts
    58
    "public" is a synonym for "guest ok".

    Try to set

    Code:
    [global]
    ...
    security = share
    ...
    
    [share1]
    guest only = yes
    guest account = lucaspewkas
    Now samba sholdn't bother with passwords any more ...

  8. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    12
    Yay it all works now.
    Thanks for your help, much appreciated
    -Luke

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •