Find the answer to your Linux question:
Results 1 to 6 of 6
I just got my box running Fedora Core 3 today, and I immediately attempted to set up my DSL connection. I expected it to be a snap, assuming I would ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    6

    Poor Performance with Fedora Core 3 and Verizon DSL


    I just got my box running Fedora Core 3 today, and I immediately attempted to set up my DSL connection. I expected it to be a snap, assuming I would just set it to use DHCP and that would be that. Well, I configured the nic and started FireFox, but alas, I had no connection. I knew that the network card worked, at least under XP, but just to be safe I switched the cable from the 3Com card I had been using to my Linksys card. I set the configuration options the same way, and started FireFox. Well, after about 10 seconds Google loaded. I typed in a test search, and it came right up. So, I tried another domain and had another 10-20 second delay. Every time I switch domains I have a huge delay, but then as long as I stay within the domain there is very little delay. I do not have this problem with any of the M$ machines in my house, so I'm lead to believe that I may just have configured something wrong. Using the "Internet Configuration Wizard/Druid/Cleric/Whatever to set up an xDsl connection doesn't work, nor does using the rp-pppoe tool. My box connects through a router which connects to the modem, the same as all the other computers on the network.

    If any of you could help me with this, I'd be much obliged.

    Oh, before I forget, there is another symptom. Downloads will for the most part work fine (with the delay, of course), but sometimes will just never start (The download will hang with the message "Starting...") or will start and stop shortly afterwards. If I hit cancel and then retry a few times it will start, but after a few tries it will completely hang.

    --BeanFlavoredWalrus

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Can you post the content of your /etc/resolv.conf?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    6
    Here's the innards of the /etc/resolv.conf file on my box:

    Code:
    ; generated by /sbin/dhclient-script
    nameserver 192.168.1.254

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    also you should consider your system specs. Under one of the Fedoras my older laptop had the same problem...fedora requires a system that is at least a little higher end on the spectrum...I changed its distro to a much faster and less bloated distro--this was before I knew about just changing window managers--and changed from gnome/kde to fluxbox and noticed a significant increase in speed. I was also using Verizon DSL at the time.
    Operating System: GNU Emacs

  6. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    6
    Well, I'll post the relevent specs, and you tell me what you think.

    Pentium 3 1000Mhz
    256Mb SDRAM
    10/100 NIC

    I'm using Gnome at the moment. As soon as my CVS script thing is done running I'll reboot into a lighter GUI and try it.

    This may be relevent, but also might just be useless information: The DSL connect seems to be the only thing running slowly, so I'm less inclined to think it's my specs. Then again, I don't know enough about linux to make accurate judgement.

  7. #6
    Just Joined!
    Join Date
    Jun 2005
    Posts
    6
    Well, I just installed Red Hat 9. The problem was indeed Fedora bloat. Thanks for your help and your time, guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •