Find the answer to your Linux question:
Results 1 to 7 of 7
I just got a US robotics external from Ebay. I found a serial cable here that probably hasn't been used in over 10 years. So, I connected my modem to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    39

    How likely is it that a serial cable would be bad?


    I just got a US robotics external from Ebay. I found a serial cable here that probably hasn't been used in over 10 years. So, I connected my modem to the serial port but the os won't see it (XP or Linux)

    Could be 3 things:

    1) Bad Serial cable
    2) Bad Serial port
    3) Bad Modem (although it powers on, lights work, calls come through etc)

    I'm leaning towards the cable...but, don't think I've ever had one be faulty before.

    As for #2 , I tried it on my old laptap with Damn Small Linux installed and same thing.

    At least this modem has a DOA warranty if that's the case.

    What do you think?

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    First, double check that you have the right port: ttyS0, ttyS1, etc.
    I'd inspect the cable where it leaves the connector fitting: that's where it gets the most flexing, so that's where wires are likely to break. If it doesn't look bad or feel sloppy or lumpy or anything, I'd look a little deeper into software set up. Can you use a serial mouse on the port? At a text console (not an xterm console!), with a serial mouse plugged in, run 'gpm -m /dev/ttyS0 -t bare' or, for a list of types to use instead of 'bare', do 'gpm -m /dev/ttyS0 -t help | less'. If the mouse works, it's down to the cable or the modem.

    I've gotten 2 US Robotics modems from eBay. I had problems with the second one not able to dial out. I had noticed that even though the 2 modems were identical, the power supply for the second was smaller. Turns out the second PS was only good for like 600mA instead of the 1000mA rating of the factory PS.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    39
    Well, I hooked it up to an old pentium running '95. Windows picked it up right away.

    So, that leaves my serial port on this system. The ports are enabled in the bios. They only conflicts I see are:

    IRQ 9 Microsoft ACPI-Compliant System
    IRQ 9 Intel(r) 82801AA SMBus Controller

    Not sure if that means anything???

    The com ports are IRQ 3&4.

    Guess I crack open the box and have a look. To be honest, I;m not sure if I've ever used the serial port in the 6 years I've had this system.

    EDIT: I;m trouble shooting the modem in Windows as I know this system much better.

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    39
    Well, Just for kicks I opened up Hyperterminal in windows and used a connection on COM2. When I type in the terminal window, the RD and SD lights come on. Also, if I set up the modem manually, the RD and SD lights come one briefly but nothing else.

    Not sure what that means for the port...possible that it is "half" working??

    Weird...

  5. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by ShaneR
    Not sure what that means for the port...possible that it is "half" working??
    Anything less than everything is really nothing. Did you notice the very first thing I suggested: I spent, no, wasted 2 days trying to get a modem going on an older box and couldn't figure it out. After all, I knew the modem worked, and the lights would come on: I just wasn't making the connection. Of course I didn't try a different serial port ID because I was sure it was connected to ttyS0....

    Trust, but verify.
    /IMHO
    //got nothin'
    ///this use to look better

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    39
    Sorry, should have mentioned that.

    Yep...tried all available ports etc. Nada. Strange that my old win95 box (that I need to literaly pound on to boot) picks it up, but this system and my laptop won't.

    Oh well...I'll keep lookin around and see what I come up with.

    Thanks for your help

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    39
    Well, the serial port was certainly bad. So, I went out and bought a USB to serial adapter. Worked great. No problems in XP, SuSE, or Ubuntu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •