hello all,

Pls, still on my DHCP server issue, the following is a sample dhcpd.conf file I found on the linuxhomenetworking site.

ddns-update-style interim

ignore client-updates



subnet 192.168.1.0 netmask 255.255.255.0 {



# The range of IP addresses the server

# will issue to DHCP enabled PC clients

# booting up on the network



range 192.168.1.201 192.168.1.220;



# Set the amount of time in seconds that

# a client may keep the IP address


default-lease-time 86400;
max-lease-time 86400;



# Set the default gateway to be used by

# the PC clients



option routers 192.168.1.1;



# Don't forward DHCP requests from this

# NIC interface to any other NIC

# interfaces



option ip-forwarding off;



# Set the broadcast address and subnet mask

# to be used by the DHCP clients


option broadcast-address 192.168.1.255;
option subnet-mask 255.255.255.0;



# Set the DNS server to be used by the

# DHCP clients


option domain-name-servers 192.168.1.100;



# Set the NTP server to be used by the

# DHCP clients



option nntp-server 192.168.1.100;



# If you specify a WINS server for your Windows clients,

# you need to include the following option in the dhcpd.conf file:

option netbios-name-servers 192.168.1.100;



# You can also assign specific IP addresses based on the clients'

# ethernet MAC address as follows (Host's name is "laser-printer":

host laser-printer {

hardware ethernet 08:00:2b:4c:59:23;
fixed-address 192.168.1.222;

}

}

#

# List an unused interface here

#
subnet 192.168.2.0 netmask 255.255.255.0 {
}
which part of the above refers to a static IP I entered for my eth0 for the IP from my ISP...... I would just like to substitute it if it may work.

When I do "service dhcpd start" i get a series of texts(scrolled up) .....and then a "failed - exiting" prompt in red color by the lower right side.
Reading the msg coming before, im been told that my eth0 is not configured to listen to any devices. Pls how do I do this "configure eth0 to listen to devices".

thanks
Toks