Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
its more fun to do it manually...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer big_k105's Avatar
    Join Date
    May 2003
    Location
    Fargo, ND
    Posts
    901

    its more fun to do it manually
    BIG K aka Kyle
    Programming Forums
    www.kylekonline.com
    Please don\'t PM me for help-- ask in the forums instead!

  2. #12
    flw
    flw is offline
    Linux Engineer
    Join Date
    Mar 2003
    Location
    U.S.A.
    Posts
    1,025
    I have to do it manunally becasue Yast2 is not saving the gateway setting.

    In the example of:

    Code:
    kkjorsvik@dc:/etc/sysconfig/network> cat ifcfg-lo

    IPADDR=127.0.0.1
    NETMASK=255.0.0.0
    NETWORK=127.0.0.0
    BROADCAST=127.255.255.255
    STARTMODE=onboot

    kkjorsvik@dc:/etc/sysconfig/network> cat ifcfg-eth0

    BOOTPROTO='static'
    BROADCAST='192.1.1.255'
    IPADDR='192.1.1.61'
    NETMASK='255.255.255.0'
    NETWORK='192.1.1.0'
    REMOTE_IPADDR=''
    STARTMODE='onboot'
    UNIQUE='_Znp.Y3FLaENdpw9'
    WIRELESS='no'
    The gateway is not defined. The file that contains the gateway setting is what I can't find.

    other ideas?
    Dan

    \"Keep your friends close and your enemies even closer\" from The Art of War by Sun Tzu\"

  3. #13
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Hmmm, what about:
    Code:
    route add default gw 192.168.1.1
    Would this cause the kernel to remeber it?
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  4. #14
    flw
    flw is offline
    Linux Engineer
    Join Date
    Mar 2003
    Location
    U.S.A.
    Posts
    1,025
    Well I tried the above and no luck.

    I think I try grep "gateway' -r / > gateway.txt" and just wait for it to finish to see what file contain any references t a gateway. :<
    Dan

    \"Keep your friends close and your enemies even closer\" from The Art of War by Sun Tzu\"

  5. #15
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Have you RTFM my suse 7.1 came with a nice big manual

  6. #16
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    due to ol' man's post, i just remembered that i have the admin guide for 8.2... the cfg files are located at:
    /etc/sysconfig/network/ifcfg-eth?
    it also says to consult the manual for 'ifup' for the complete list of variable for the network config..
    also, routing info is in the following places:
    /etc/sysconfig/network/routes
    /etc/sysconfig/network/ifroute-*

    hope that helps
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  7. #17
    Linux Engineer big_k105's Avatar
    Join Date
    May 2003
    Location
    Fargo, ND
    Posts
    901
    the ifcfg-eth0 file says nothing about gateway tho and thats what he is trying to find out how to set.
    BIG K aka Kyle
    Programming Forums
    www.kylekonline.com
    Please don\'t PM me for help-- ask in the forums instead!

  8. #18
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Edit -> /etc/sysconfig/network/routes , And add -> default: 192.168.1.254 - eth1

    Obviousely change the IP to your gateways ip and eth1 to your device, And it seems that you can do it with yast2 so just type yast2 IIRC

  9. #19
    flw
    flw is offline
    Linux Engineer
    Join Date
    Mar 2003
    Location
    U.S.A.
    Posts
    1,025
    Incase anyone is looking for the proxy settings file its in /etc/sysconfig/proxy

    My problem has taken a turn (since I discovered it was saving the settings) into the network service just not starting properly for eth1 rather than not saving the settings. Sorry about that .

    I'm going to check over my /var/log/msg and see if there is anything obvious.
    Dan

    \"Keep your friends close and your enemies even closer\" from The Art of War by Sun Tzu\"

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •