Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
When I give samba the net ads join -U Administrator command, I get the following output on my screen: [root@ICARUS etc]# net ads join -U Administrator Administrator's password: Using short ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    23

    Samba +AD +Error?


    When I give samba the net ads join -U Administrator command, I get the following output on my screen:

    [root@ICARUS etc]# net ads join -U Administrator
    Administrator's password:
    Using short domain name -- GOLDENEYE-THUIS
    Joined 'ICARUS' to realm 'GOLDENEYE-THUIS.LOCAL'

    *** glibc detected *** net: free(): invalid pointer: 0x001957f0 ***
    ======= Backtrace: =========
    /lib/libc.so.6[0x46e424]
    /lib/libc.so.6(__libc_free+0x77)[0x46e95f]
    /lib/libcom_err.so.2(remove_error_table+0x4b)[0x196abb]
    /usr/lib/libkrb5.so.3[0x133823]
    /usr/lib/libkrb5.so.3[0x1335c7]
    /usr/lib/libkrb5.so.3[0x1843ba]
    /lib/ld-linux.so.2[0x3a3058]
    /lib/libc.so.6(exit+0xc5)[0x435c69]
    /lib/libc.so.6(__libc_start_main+0xce)[0x41fdee]
    net[0xc070f1]
    ======= Memory map: ========
    00111000-00120000 r-xp 00000000 fd:00 4775868 /lib/libresolv-2.3.5.so
    00120000-00121000 r-xp 0000e000 fd:00 4775868 /lib/libresolv-2.3.5.so
    00121000-00122000 rwxp 0000f000 fd:00 4775868 /lib/libresolv-2.3.5.so
    00122000-00124000 rwxp 00122000 00:00 0
    00124000-00193000 r-xp 00000000 fd:00 8550453 /usr/lib/libkrb5.so.3.2
    00193000-00196000 rwxp 0006e000 fd:00 8550453 /usr/lib/libkrb5.so.3.2
    00196000-00198000 r-xp 00000000 fd:00 4775869 /lib/libcom_err.so.2.1
    00198000-00199000 rwxp 00001000 fd:00 4775869 /lib/libcom_err.so.2.1
    00199000-001ce000 r-xp 00000000 fd:00 4775871 /lib/libssl.so.0.9.7f
    001ce000-001d1000 rwxp 00035000 fd:00 4775871 /lib/libssl.so.0.9.7f
    001d1000-001e3000 r-xp 00000000 fd:00 8550450 /usr/lib/libz.so.1.2.2.2
    001e3000-001e4000 rwxp 00011000 fd:00 8550450 /usr/lib/libz.so.1.2.2.2
    001e4000-001ed000 r-xp 00000000 fd:00 4774837 /lib/libnss_files-2.3.5.so
    001ed000-001ee000 r-xp 00008000 fd:00 4774837 /lib/libnss_files-2.3.5.so
    001ee000-001ef000 rwxp 00009000 fd:00 4774837 /lib/libnss_files-2.3.5.so
    00259000-00260000 r-xp 00000000 fd:00 8546751 /usr/lib/libpopt.so.0.0.0
    00260000-00261000 rwxp 00006000 fd:00 8546751 /usr/lib/libpopt.so.0.0.0
    00329000-0032a000 r-xp 00329000 00:00 0
    00395000-003af000 r-xp 00000000 fd:00 4775858 /lib/ld-2.3.5.so
    003af000-003b0000 r-xp 00019000 fd:00 4775858 /lib/ld-2.3.5.so
    003b0000-003b1000 rwxp 0001a000 fd:00 4775858 /lib/ld-2.3.5.so
    003dd000-003e2000 r-xp 00000000 fd:00 4775876 /lib/libcrypt-2.3.5.so
    003e2000-003e3000 r-xp 00004000 fd:00 4775876 /lib/libcrypt-2.3.5.so
    003e3000-003e4000 rwxp 00005000 fd:00 4775876 /lib/libcrypt-2.3.5.so
    003e4000-0040b000 rwxp 003e4000 00:00 0
    0040b000-0052f000 r-xp 00000000 fd:00 4775859 /lib/libc-2.3.5.so
    0052f000-00531000 r-xp 00124000 fd:00 4775859 /lib/libc-2.3.5.so
    00531000-00533000 rwxp 00126000 fd:00 4775859 /lib/libc-2.3.5.so
    00533000-00535000 rwxp 00533000 00:00 0
    005e3000-005ec000 r-xp 00000000 fd:00 4775864 /lib/libgcc_s-4.0.0-20050520.so.1
    005ec000-005ed000 rwxp 00009000 fd:00 4775864 /lib/libgcc_s-4.0.0-20050520.so.1
    00633000-00648000 r-xp 00000000 fd:00 8537211 /usr/lib/libsasl2.so.2.0.20
    00648000-00649000 rwxp 00015000 fd:00 8537211 /usr/lib/libsasl2.so.2.0.20
    00649000-00741000 r-xp 00000000 fd:00 4775870 /lib/libcrypto.so.0.9.7f
    00741000-00753000 rwxp 000f8000 fd:00 4775870 /lib/libcrypto.so.0.9.7f
    00753000-00756000 rwxp 00753000 00:00 0
    007be000-007e1000 r-xp 00000000 fd:00 8550452 /usr/lib/libk5crypto.so.3.0
    007e1000-007e2000 rwxp 00023000 fd:00 8550452 /usr/lib/libk5crypto.so.3.0
    00808000-0081e000 r-xp 00000000 fd:00 8550454 /usr/lib/libgssapi_krb5.so.2.2
    0081e000-0081f000 rwxp 00016000 fd:00 8550454 /usr/lib/libgssapi_krb5.so.2.2
    00859000-0088d000 r-xp 00000000 fd:00 8550532 /usr/lib/libldap-2.2.so.7.0.16
    0088d000-0088f000 rwxp 00033000 fd:00 8550532 /usr/lib/libldap-2.2.so.7.0.16
    009ca000-009d7000 r-xp 00000000 fd:00 8545200 /usr/lib/liblber-2.2.so.7.0.16
    009d7000-009d8000 rwxp 0000c000 fd:00 8545200 /usr/lib/liblber-2.2.so.7.0.16
    00aa7000-00aa9000 r-xp 00000000 fd:00 8601334 /usr/lib/gconv/IBM850.so
    00aa9000-00aab000 rwxp 00001000 fd:00 8601334 /usr/lib/gconv/IBM850.so
    00bda000-00d9e000 r-xp 00000000 fd:00 8543848 /usr/bin/net
    00d9e000-00daf000 rwxp 001c4000 fd:00 8543848 /usr/bin/net
    00daf000-00dc1000 rwxp 00daf000 00:00 0
    00de1000-00df3000 r-xp 00000000 fd:00 4775866 /lib/libnsl-2.3.5.so
    00df3000-00df4000 r-xp Aborted



    Then when I look in my active directory, the samba is actually joined, so nothing seems to be wrong.
    But then again, the wbinfo -u command gives me the "Error looking up domain users"

    Does anyone know what this means ?

  2. #2
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    It's looking if something isn't correct configured:

    Either the kernel or samba isn't configured good at all.
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    23
    Strange

    It is a basic fresh installation of FC4. Didn't change anything to the kernell / samba.

    Only krb5.conf and smb.conf but the syntax of those files is correct.

    Where do I start the search on this ?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    23
    Well it seems I've got a little further.

    I've upgraded to the latest samba version available and now I get the following error message when starting the smb service.

    First it seems that smbd and nmbd are starting ok. But when I ask the status it says that smbd is DEAD.

    When I look at the log file, I know WHY:

    [2005/08/10 00:45:42, 0] groupdb/mapping.c:init_group_mapping(134)
    Failed to open group mapping database
    [2005/08/10 00:45:42, 0] groupdb/mapping.c:get_group_map_from_gid(275)
    failed to initialize group mapping
    [2005/08/10 00:45:42, 3] smbd/sec_ctx.cop_sec_ctx(386)
    pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 1
    [2005/08/10 00:45:42, 3] smbd/sec_ctx.cop_sec_ctx(386)
    pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
    [2005/08/10 00:45:42, 0] lib/account_pol.c:init_account_policy(52)
    Failed to open account policy database
    [2005/08/10 00:45:42, 0] lib/account_pol.c:init_account_policy(52)
    Failed to open account policy database
    [2005/08/10 00:45:42, 0] lib/account_pol.c:init_account_policy(52)
    Failed to open account policy database


    FAILED TO OPEN ....
    It seems that samba has no rights to these databases OR they don't exist !
    How do I fix this ? Where are these located ?

    [EDIT]
    Winbindd service won't start either (same DEAD error, when asking for status). But I think this has something to do with the smb service not running.
    [/EDIT]

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Just curious if you had any progress on this, I have a similar problem and I've seen that a lot of people have this problem, but not a single person has suggested a resolution. I've read that it's actually related to the e2fsprogs, and error handling, but I haven't had a chance to try this. I've also read that this is a bug in krb5, here's what I've found:

    http://www.webservertalk.com/message1139582.html

    https://bugzilla.redhat.com/bugzilla....cgi?id=164353

    I've tried just about everything to no avail.

  7. #6
    Just Joined!
    Join Date
    Apr 2004
    Posts
    23
    Well I've got it to work !

    I steped aside from Fedora Core and am now running the better SUSE 9.3.
    After this I've upgraded to the latest samba suite (VIA SOURCE !!) not rpm.
    The compilation of samba was done with the --with-winbind and --with-pam options. Note that when using SUSE, the compilation of PAM can give an error because the libraries aren't found. You should install these manually (via rpm).
    When all this was done, I had to do 2 more things. Manually copy the pam_winbindd.so and libnss to their right directories.

    I configed smb.conf and krb5.conf. Restart smbd, winbind and nmbd services.
    net ads join -U Administrator, wbinfo -u, wbinfo -g, getent passwd everything worked.

  8. #7
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Can you list the versions of the packages you installed? I'm not gonna switch distro's, but that might help in resolving my issues. Thanks!

    P.S
    Congrats on figuring it out.

  9. #8
    Just Joined!
    Join Date
    Apr 2004
    Posts
    23
    Samba Suite:
    smbd: v3.0.14a
    nmbd: v3.0.14a
    winbind: v3.0.14a
    samba library: v3.0.14a

    Kerberos:
    krb5: 1.4-16.4
    pam_krb5: 1.3-208.4

    Kernel:
    2.6.11.4-21.8

    Since u are using Fedora, I suggest you'll disable the internal security suite of Fedora (caused alot of problems here too). I'm not sure what's it called.

    Tips:
    When you've compiled the samba suite with the --with-winbind and --with-pam do the following:

    Copy libnss_winbind.so from the source of samba to the /lib directory
    Make a symbolic link from libnss_winbind.so to libnss_winbind.so.2
    Copy pam_winbind.so from the source of samba to the /lib/security directory.

    For some reason, the make install script sometimes doesn't copy those files.
    If, like me, you have a previous install of samba, make sure to delete these files first (including symbolic link) before copying them.

    GOOD LUCK!

  10. #9
    Linux Newbie
    Join Date
    May 2005
    Location
    Chennai,TamilNadu, India
    Posts
    141
    getent passwd, wbinfo -u and wbinfo -g these give the same information..
    but net user and net group give a different information..

    The difference is kinda like the computer name dont get listed in net user and net group...

    why do the computer names get listed in getent passwd, wbinfo -u??

    does samba have anything to do with this....

  11. #10
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    As far as I can tell, the reason that everything is listed in getent passwd etc. is because these commands don't distinguish between OU's (Organizational Units). Really, without the AD framework, these are all the same thing, just entries in a database, you need AD tools to then organize those items into their respective groups.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •