Find the answer to your Linux question:
Results 1 to 6 of 6
I have a Linksys Wireless-G WUSB54G NIC. This receives a signal from my Linksys router, which is connected to my Westell Modem. I'm using Fedora Core 3. I downloaded and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    108

    Connecting to the Internet through USB Adapter


    I have a Linksys Wireless-G WUSB54G NIC. This receives a signal from my Linksys router, which is connected to my Westell Modem. I'm using Fedora Core 3.

    I downloaded and compiled ndiswrapper, got the .inf drivers. It says this when I do ndiswrapper -l.
    Installed ndis drivers:
    wusb54g driver present, hardware present
    But now it says this when I do iwconfig:
    lo no wireless extensions.

    eth0 no wireless extensions.

    Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
    but has been compiled with version 16, therefore some driver features
    may not be available...

    wlan0 IEEE 802.11g ESSID:off/any Nickname:"localhost.localdomain"
    Mode:Ad-Hoc Frequency:2.437GHz Cell: 00:00:00:00:00:00
    Bit Rate=2Mb/s
    RTS thr=2432 B Fragment thr=2346 B
    Power Management:off
    Link Quality:100 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:967 Missed beacon:0

    sit0 no wireless extensions.
    I would just set up a PPPoE connection for my Verizon DSL internet, but eth0 is not working. According to system-config-network, wlan0 is active, but there is no eth0.

    My computer does not use a PCI Ethernet card. It only uses the USB Linksys NIC adapter. I am very confused about getting my internet connection to work through the router.

    I was under the impression that my adapter should be eth0, but I don't have the option of converting it from wlan0 to eth0.

    The Internet works when I'm on my Windows partition, but not for Linux.

    According to my router settings, it's in Ad-Hoc mode. Should this be changed?

    Also, when I'm creating a new xDSL connection, it doesn't give me the option of using my wireless NIC. It forces me to use ethX, where X is a digit.

    I'm using Fedora Core 3, so I decided to use the GUI.

    dhclient wlan0 does this, I don't know if it's good or bad:
    Internet Systems Consortium DHCP Client V3.0.1
    Copyright 2004 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/products/DHCP

    sit0: unknown hardware address type 776
    sit0: unknown hardware address type 776
    Listening on LPF/wlan0/00:0f:66:71:54:70
    Sending on LPF/wlan0/00:0f:66:71:54:70
    Sending on Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    Here are some screenshots that may be helpful in solving my problems.

    Network Devices:

    Wireless Device Settings:

    General Wireless Settings:


    Thanks for the help!

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    what is the output of
    Code:
    ifconfig
    run as root
    iwconfig just lists the wireless connections ifconfig lists all nic's and the ip assigned to them we need to see with that command if wlan0 has been started(brought up) if not then we need to know this so it can be brought up so please paste the output of ifconfig
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #3
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    108

    IFCONFIG

    eth0 Link encap:Ethernet HWaddr 00:0C:6E:B3:CA:C5
    BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:177 Base address:0xb400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1771 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1771 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2764938 (2.6 MiB) TX bytes:2764938 (2.6 MiB)

    sit0 Link encap:IPv6-in-IPv4
    NOARP MTU:1480 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    wlan0 Link encap:Ethernet HWaddr 00:0F:66:71:54:70
    inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::20f:66ff:fe71:5470/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    ok, so it looks like it got the address, but it is not associating with the AP. In one of your posts, you said that router is set up in Ad-hoc mode, but your screenshot says it is in managed mode (If i were you, i would make router into Managed mode, Ad-hoc is when there is no router/ap present).

    Secondly execute the following commands as root:
    Code:
    iwlist wlan0 scan
    iwconfig wlan0 ssid My_SSID
    iwconfig wlan0 key xxxxxxxxxxxxx
    iwconfig
    In the last iwconfig command, if everything worked fine, the entry next to CEll/AP should be something other than 00:00:00:00:00:00.
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    108
    My router is in managed mode, I was changing it.

    I will execute those commands and see what happens.

  6. #6
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    108
    YAHOOOOOOOOOOOOOOOOOOOO!

    After 3 months of hard work, the Internet can be viewed through Linux!

    Thank you lots AlexK!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •