Find the answer to your Linux question:
Results 1 to 2 of 2
Hello everyone. I have been using Linux for awhile now and I am have gotten comfortable with it. I built Gentoo successfully and I wanted to learn more so I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    3

    Networking interfaces no-existant?


    Hello everyone.

    I have been using Linux for awhile now and I am have gotten comfortable with it. I built Gentoo successfully and I wanted to learn more so I dove into LFS. (Linux from scratch) I have now booted into my system.

    The problem that I am having is that my network interfaces aren't being detected.

    I have a 10/100 nic built into my motherboard (Nforce2), that's eth0. Eth1 is a 10/100/1000 PCI Netgear card which is plugged into an internet connected switch. I was able to: ifcfg eth1 add && dhcpcd eth1 on the LFS live cd but when I boot into my newly created lfs system I am unable to do so. I receive the following
    ifcfg eth1 add

    Code:
    /sbin/ifcfg: line 25: [: too many arguments
    /sbin/ifcfg: line 26: [: -ge: unary operator expected
    /sbin/ifcfg: line 27: [: -ge: unary operator expected
    /sbin/ifcfg: line 28: [: -ge: unary operator expected
    SIOCFIFFLAGS: No such device
    Error: cannot enable interface eth1.
    I have all of the appropriate init scripts and dhcpcd installed, but obviously the network related init scripts are failing. I even tried copying the init scripts off of the LFS live cd. This leads me to believe that there are driver issues. After checking /sys/class/net there doesn't appear to be any eth* nodes (although I am not sure this is where the should be) and the same goes for /dev

    1.) Perhaps the kernel isn't compiled correctly?
    2.) Is there a necessary step that I missed to add the device?

    Thanks for your help.

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Posts
    1
    Hi Glass.

    No replies to your query... and I have to apologize for not having the answer either. I'm having the same problem when I insert my PCMCIA ethernet card.

    The scripts that ship with LFS and BLFS should be bringing up the interface automatically when I insert the card, but no such luck. When I reboot, however.... (rebooting now...)

    well, I still get the problem with `ifcfg eth0` (/sbin/ifcfg: line 25: [: too many arguments, etc.), but the bootlog reported no problems bringing up eth0, assigning an ip address, or setting the default gw; so... i guess I have to dig.

    Maybe you know where I should look in my boot scripts for what commands are working for me during boot, but not during hotplug, and which are not working for you on your eth1 during boot.

    I'm going to go install a dhcp client now... wish me luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •