Hi,


SOLVED!!

With the help of Google and

http://www.justlinux.com/forum/printthread.php?t=142184

I added

#!/bin/sh
#
# /etc/rc.d/rc.local: Local system initialization script.
#
# Put any local setup commands in here:

echo "Connecting to linksys/Martin"
iwconfig ath0 essid "linksys"
iwlist ath0 scan
iwconfig ath0 essid "linksys"
iwconfig ath0 mode "Managed"
iwconfig ath0 rate "auto"
ifconfig ath0 up
iwconfig
/sbin/dhcpcd ath0

to /etc/rc.d/rc.local

Now EVERYTHING works!

The /sbin/dhcpcd ath0 must have done the trick.

I'm happy.... lol.

Thanks anyway, hope this helps reference wise..


UPDATE

I can now log in to my router and change settings via wireless.
But I still get www.google.com cannot be found from Firefox.
What should I put in resolv.conf?
I have configured slackware for loopback only, as the installation script recommended that. So there is no dhcp assignment it seems like.
Can I use some type of dhcp command to obtain an IP address??

UPDATE

when I do

ifconfig ath0 192.168.1.103 netmask 255.255.255.0

and then

ping -c 4 192.168.1.1

I get

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3015ms
rtt min/avg/max/mdev = 0.429/0.740/1.542/0.465 ms

So I can at least ping the router when I manually set the ifconfig for ath0.
But ping www.google.com still gives
connect: Network is unreachable



----

With reference to the numerous threads on this forum I have bought a Atheros based Netgear WG511T, succesfully cvs'ed the latest madwifi source, succesfully made and installed madwifi and indeed the card is installed correctly.
I got the light, if I tell KDE to autodetect the interface ath0 comes up, if I apply the config both lights starts the search sequence but I'm not picking up any network.

iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

ath0 IEEE 802.11 ESSID:""
Mode:Managed Frequency:2.412GHz Access Point: 00:00:00:00:00:00
Bit Rate:0kb/s Tx-Power:20 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0/94 Signal level:-95 dBm Noise level:-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

dmesg:

ath_hal: 0.9.14.9 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413)
wlan: 0.8.6.0 (EXPERIMENTAL)
ath_rate_sample: 1.2
ath_pci: 0.9.6.0 (EXPERIMENTAL)
Build date: Sep 2 2005
Debugging version (IEEE80211)
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: turboG rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: H/W encryption support: WEP AES AES_CCM TKIP
ath0: mac 5.6 phy 4.1 radio 4.6
ath0: Use hw queue 1 for WME_AC_BE traffic
ath0: Use hw queue 0 for WME_AC_BK traffic
ath0: Use hw queue 2 for WME_AC_VI traffic
ath0: Use hw queue 3 for WME_AC_VO traffic
ath0: Use hw queue 8 for CAB traffic
ath0: Use hw queue 9 for beacons
Debugging version (ATH)
ath0: Atheros 5212: mem=0x10800000, irq=11

ifconfig:

eth0 Link encap:Ethernet HWaddr XXXXXXXXXXXX
inet addr:192.168.1.103 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:126 errors:0 dropped:0 overruns:0 frame:0
TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:58446 (57.0 Kb) TX bytes:26752 (26.1 Kb)
Interrupt:11 Base address:0x5000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

I can't seem to get KDE to remember the config1/2/3/4 because when I press apply after selecting the preferences such as ssid ... and then close
the control center, all settings are lost.
I'm writing this 'through' the Ethernet cable directly connected to the router.

What can be the problem?
Can I manually edit a config file?

I hope you can help.

Thanks a lot in advance,

Marinus.

Update:

iwconfig:

IEEE 802.11b ESSID:"linksys"
Mode:Managed Frequency:2.437GHz Access Point: XXXXXXXXXXX
Bit Rate=11Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:46/94 Signal level:-49 dBm Noise level:-95 dBm
Rx invalid nwid:47 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:2 Missed beacon:2


I'm getting there I think...
I can now through KDE turn it on, but Firefox still only relies on the UTP link.
What is the commandline command to turn the PCMCIA card on, just like you do in KDE?

Update:

ping -c 4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.103 icmp_seq=1 Destination Host Unreachable
From 192.168.1.103 icmp_seq=2 Destination Host Unreachable
From 192.168.1.103 icmp_seq=3 Destination Host Unreachable
From 192.168.1.103 icmp_seq=4 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3025ms
, pipe 3

Should I try pinging another address, or could my router be the problem?
I'm writing this on another machine trough a wireless PIC NIC through the same router.
What I'm also thinking is that ping is routing through my ethernet card, so no packets ofcourse make it through.
Can I simply disable my ethernet card?

Many questions, I know.

Getting desperate

Thanks, Marinus.