Find the answer to your Linux question:
Results 1 to 5 of 5
I'm trying to network two computers. System 1 is an AMD box running Mandriva 10.2, and system 2 is a P4 box with a dual boot of Win XP and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95

    Can connect to Samba share in Windows, but not in Linux.


    I'm trying to network two computers. System 1 is an AMD box running Mandriva 10.2, and system 2 is a P4 box with a dual boot of Win XP and Mandriva 10.2. I've shared a folder on the AMD box, and am able to map a drive letter to it from the P4 box in XP, and everything works. However, I'm not able to connect to the share when I boot into Mandriva.

    SWAT Status Excerpts from AMD machine (printer and PDF related sections ommitted for space):
    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2005/09/03 23:09:12

    # Global parameters
    [global]
    workgroup = FAMILY
    netbios name = AMD
    server string = Samba Server %v
    map to guest = Bad User
    log file = /var/log/samba/log.%m
    max log size = 50
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    printcap cache time = 60
    printcap name = cups
    dns proxy = No
    printer admin = @adm

    [amdshare]
    path = /home/redbeard/shared
    read only = No
    guest ok = Yes
    To mount the share on the P4 box, I've added the following line to fstab:
    Code:
    //Amd/amdshare /mnt/amd smbfs noauto,user 0 0
    This doesn't mount the share automatically, and when I tried to manually mount it I received the following error message:
    [root@localhost redbeard]# mount //AMD/amdshare
    10534: Connection to AMD failed
    SMB connection failed
    Does anyone have any suggestions? I feel like I'm very close to making this work, but must be overlooking some detail somewhere. Sorry for the long post, I just wanted to provide the details in case that helps. Any assistance would be greatly appreciated!

  2. #2
    Linux User
    Join Date
    Aug 2005
    Location
    Peterborough, UK
    Posts
    379
    Although this was for a different problem with Samba (I was connecting to a W2k3 server, not a Linux one), it may help to use 'cifs' instead of 'smbfs'.

    I may, of course, be totally mistaken, as your server may not be serving a cifs share whereas Windows does, but it may be worth a try...
    \"I am, after all,\" said Pooh, \"a bear of very little brain.\"
    MY PC: Athlon XP64 3000+ on a Asus K8V-X mobo w/1GB of non-descript RAM. AGP - GeForce 2 MX400. PCI - Creative Live! 5.1 soundcard. 140 GB and 120 GB SATA WD drives.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95
    Thanks for the suggestion! I tried changing that part of the line, but it still won't connect. Now I get a different error when I try to mount manually though, so maybe this will help:
    [root@localhost redbeard]# mount //AMD/amdshare
    mount error: could not find target server. TCP name AMD/amdshare not found rc = -1073744520
    No ip address specified and hostname not found

  4. #4
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95

    More info

    I was reading through the SMB HOWTO, and saw a line to tell what shares were seen by the client box (P4) from the server (AMD). I ran this line on the P4 box, and this is what I got:
    Code:
    [root@localhost redbeard]# /usr/bin/smbclient -L AMD
    Connection to AMD failed
    I'm assuming this error means I don't have the right services/settings on the P4 to even see the AMD machine. I'm just not sure what to test. I did go into SWAT and look at the "status" tab for the P4 system, and noticed that two services aren't running:
    version: 3.0.13
    smbd: not running
    nmbd: running
    winbindd: not running
    I tried starting the two services, and even stopped all three and tried starting all at once, but can't make either smbd or winbindd run. Does this sound like where my problem likely lies? Can anyone suggest some tips on how to get these services running?

  5. #5
    Linux Newbie pajamabama's Avatar
    Join Date
    Jul 2005
    Location
    In another time's forgotten space
    Posts
    150
    I'm not an expert on this, so please someone tell me if I'm totally off base here.

    I think that smbd is only needed for serving a Samba share, not to connect to one. You should have it running on your AMD box, right?

    Also, have you tried running smbmount instead of mount? Or explicitly telling it to use the smbfs?

    Code:
    mount -t smbfs //AMD/amdshare /mountpoint -o username=<user>
    Just some thoughts, I've been dealing with this stuff a whole lot lately.
    HP Pavilion dv6000t
    Intel Centrino Duo 2.0GHz
    nVidia GeForce Go 7400
    Fedora 10

    ----------------------
    The real question is what time is it and why the hell am I still screwing around with my computer?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •