Find the answer to your Linux question:
Results 1 to 5 of 5
Alright I've been trying to get my wireless network to connect on boot. After much fiddling with the interfaces file I've given up and chosen instead to create a little ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Maryland, USA
    Posts
    103

    Ubuntu Wireless On Boot Connect


    Alright I've been trying to get my wireless network to connect on boot. After much fiddling with the interfaces file I've given up and chosen instead to create a little shell script that just runs the basic iwconfig commands. But now I have some free time and I'm trying to figure out exactally what part of the interfaces file is wrong

    Here's the file

    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # This is a list of hotpluggable network interfaces.
    # They will be activated automatically by the hotplug subsystem.
    mapping hotplug
            script grep
            map eth1
    #       map eth0
    
    # The primary network interface
    iface eth1 inet dhcp
            # wireless-* options are implemented by the wireless-tools package
            wireless-mode managed
            wireless-essid ""
            wireless-key #########
    
    # iface eth0 inet dhcp
    
    
    
    iface eth0 inet dhcp
    
    
    
    auto eth1

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    You'll need you ESSID to get it working properly. My /etc/network/interfaces file looks like this:

    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # iface eth0 inet dhcp
    
    # The primary network interface
    
    auto atml0
    iface atml0 inet dhcp
      wireless-essid Wireless Connection
      wireless-channel 1
      wireless-mode adhoc
      wireless-nick DebLinux
      wireless-rts 2304
      wireless-frag 2304
    You absolutely need your ESSID in there with no " (even if it has spaces like mine); the channel number (mine is 1 as you can see); and the mode, adhoc if you want to be able to get out of you LAN. Mine has a few extra things in there just because I found it works best that way.

  3. #3
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Maryland, USA
    Posts
    103
    Alright I pretty much cut and pasted what you posted and still no luck.

    I made a few changes
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # iface eth0 inet dhcp
    
    # The primary network interface
    
    auto eth1
    iface eth1 inet dhcp
      wireless-essid Wireless Connection
      wireless-channel 6
      wireless-mode adhoc
      wireless-nick Ubuntu
      wireless-rts 2304
      wireless-frag 2304
      wireless-key ##########
    I assume that the channel is the wireless channel, which is in my case 6.

    I don't understand exactally what rts and frag are for though

  4. #4
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Maryland, USA
    Posts
    103
    Scratch that, I had the wrong ESSID. Probem solved.


    I'm still curious about those two settings though

  5. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    To tell you the truth I'm not sure what they mean either, but you might want to take them off yours. It's something that is defined in the router and when I installed all it in Windows (I called Customer Support and they told me to define it that way) it would only work with that threshold. The full name in the router configuration is RTS threshold and Fragmentation threshold.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •