Find the answer to your Linux question:
Results 1 to 6 of 6
Hi All, I've exhausted my knowledge of Linux networking and need some help with a seemingly impossible problem. What I'm trying to do is very simple, even for me. I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    4

    NFS and permission denied error


    Hi All,

    I've exhausted my knowledge of Linux networking and need some help with a seemingly impossible problem.

    What I'm trying to do is very simple, even for me. I'm trying to set up a standard NFS client/server between two machines running Mandrake 10.1 with the default kernel version (2.6.8.1-12mdk). After quadruple checking my configurations and service status, I am receiving "Permission Denied" errors from the server. The funny part (not really) is that I had this working with very little effort a month ago. Then I had to muck with the system and I can't get it working again! I've tried everything I know of and could find online, but to no avail.

    I'll post any relevant system configuration files and cmd line output that may help. Do you see anything that I'm missing or misconfiguring??? If there's something else you would like to see, please tell me. Any help at this point is greatly appreciated!

    ********** Server Config (myserver) *************
    /etc/hosts
    Code:
    [root@myserver root]# cat /etc/hosts
    127.0.0.1               localhost
    129.190.219.122         myserver
    129.190.219.116         myclient
    /etc/exports
    Code:
    [root@myserver root]# cat /etc/exports
    /home/username/src    myclient(rw,no_root_squash,sync)
    Checking the export directory's permissions:
    Code:
    [root@myserver root]# ls -l /home/username/
    total 12
    drwx------  3 username username 4096 Apr 11 04:43 Desktop/
    drwxrwxrwx  4 username username 4096 Sep 14 15:19 src/
    drwx------  5 username username 4096 Sep 19 14:48 tmp/
    [root@myserver root]# ls -l /home/username/src/
    total 8
    drwxrwxr-x  6 username username 4096 Jun  3 12:47 dir1/
    drwxrwxr-x  2 username username 4096 May 30 14:35 dir2/
    After this, I did a 'exportfs -ra' to reread the /etc/exports file.

    Checking if NFS is running on my server...
    Code:
    [root@myserver root]# rpcinfo -p
       program vers proto   port
        100000    2   tcp    111  portmapper
        100000    2   udp    111  portmapper
        100024    1   udp    745  status
        100024    1   tcp    748  status
        391002    2   tcp   1024  sgi_fam
        100003    2   udp   2049  nfs
        100003    3   udp   2049  nfs
        100003    4   udp   2049  nfs
        100003    2   tcp   2049  nfs
        100003    3   tcp   2049  nfs
        100003    4   tcp   2049  nfs
        100021    1   udp   1030  nlockmgr
        100021    3   udp   1030  nlockmgr
        100021    4   udp   1030  nlockmgr
        100021    1   tcp   1051  nlockmgr
        100021    3   tcp   1051  nlockmgr
        100021    4   tcp   1051  nlockmgr
        100005    1   udp    761  mountd
        100005    1   tcp    764  mountd
        100005    2   udp    761  mountd
        100005    2   tcp    764  mountd
        100005    3   udp    761  mountd
        100005    3   tcp    764  mountd
    Checking what is being exported on my server...
    Code:
    [root@myserver root]# showmount -e localhost
    Export list for localhost:
    /home/username/src myclient
    /etc/hosts.allow and /etc/hosts.deny are deleted

    Mandriva's Shorewall firewall is not installed:
    Code:
    [root@myserver root]# rpm -qa | grep shore
    [root@myserver root]#
    After trying to connect from the client, /var/log/messages appended this line:
    Code:
    [root@myserver root]# tail -1 /var/log/messages
    Sep 19 16:18:33 myserver rpc.mountd: authenticated mount request from myclient:934 for /home/username/src (/home/username/src)
    ********** Client Config (myclient) *************
    /etc/hosts
    Code:
    [root@myclient root]# cat /etc/hosts
    127.0.0.1               localhost
    129.190.219.116         myclient
    129.190.219.122         myserver
    /etc/fstab
    Code:
    [root@myclient root]# cat /etc/fstab
    /dev/hda5 / ext3 noatime 1 1
    /dev/hda7 /home ext3 noatime 1 2
    /dev/hdc /mnt/cdrom auto umask=0022,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
    /dev/hda1 /mnt/windows vfat umask=0022,iocharset=iso8859-1,codepage=850 0 0
    none /proc proc defaults 0 0
    /dev/hda6 swap swap defaults 0 0
    /dev/sda1 /mnt/removable auto umask=0,user,iocharset=iso8859-1,sync,kudzu,codepage=850,noauto,exec,users 0 0
    myserver:/home/username/src /mnt/mydir nfs rw 0 0
    Checking the mount point exists (and viewing its owner/permissions):
    Code:
    [root@myclient root]# ls -l /mnt
    total 28
    drwxr-xr-x   2 root root  4096 Aug 26 15:19 mydir/
    Checking what is currently mounted:
    Code:
    [root@myclient root]# mount
    /dev/hda5 on / type ext3 (rw,noatime)
    none on /proc type proc (rw)
    none on /proc/bus/usb type usbfs (rw)
    none on /sys type sysfs (rw)
    /dev/hda7 on /home type ext3 (rw,noatime)
    /dev/hda1 on /mnt/windows type vfat (rw,umask=0022,iocharset=iso8859-1,codepage=850)
    /etc/hosts.allow and /etc/hosts.deny are the default for Mandrake's 'standard' security level (blank).

    Mandriva's Shorewall firewall is installed, but not running:
    Code:
    [root@myclient root]# rpm -qa | grep shore
    shorewall-2.0.17-1.1.102mdk
    [root@myclient root]# service shorewall stop
    Loading /usr/share/shorewall/functions...
    Processing /etc/shorewall/params ...
    Processing /etc/shorewall/shorewall.conf...
    Loading Modules...
    Clearing Shorewall...Processing /etc/shorewall/stop ...
       WARNING: DISABLE_IPV6=Yes in shorewall.conf but this system does not appear to have ip6tables
    IP Forwarding Enabled
    Processing /etc/shorewall/stopped ...
    done.
    My attempt to mount the file system...
    Code:
    [root@myclient root]# mount /mnt/mydir/
    mount: myserver:/home/username/src failed, reason given by server: Permission denied

  2. #2
    Linux User
    Join Date
    Jan 2005
    Location
    Florida
    Posts
    414
    I can't tell from what you have posted what might be causing your nfs woes but here are some of the web sites that I found helpfull in sorting out my own problems.
    nfs gotchas
    iptables
    home networking

    All three of these sites had useful information but I had to do a lot of reading before I found what I was looking for. I think the gotchas page was probably most helpful in the end for me.

    Good luck and enjoy your reading
    registered linux user: 387197

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    The solution

    you can solve the problem adding the following lines in /etc/fstab on the server side:

    nfsd /proc/fs/nfsd nfsd auto,defaults 0 0
    sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs auto,defaults 0 0

    Then type on the server
    mount -a

    And try to mount de resource in the client

    --
    Albert Sellarès GPG id: 0xB88C621A
    http://www.wekk.net whats_up@jabber.org
    Membre de Catux.org http://catux.org
    Linux User: 324456 Catalunya

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    4

    NFS and permission denied error [SOLVED]

    I had looked through countless man pages, wiki's, forums, and howtos and haven't come across anything that told me I should try modifying my server's /etc/fstab settings! The first line (nfsd /proc/fs/nfsd nfsd auto,defaults 0 0) solved the problem. The second line (sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs auto,defaults 0 0) was invalid on my distro.

    After adding the two lines:
    Code:
    [root@turtle gaudetteje]# mount -a
    mount: mount point /var/lib/nfs/rpc_pipefs does not exist
    [root@turtle gaudetteje]# mount
    /dev/hda1 on / type ext3 (rw)
    none on /proc type proc (rw)
    none on /proc/bus/usb type usbfs (rw)
    none on /sys type sysfs (rw)
    /dev/hda6 on /home type ext3 (rw)
    none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850)
    nfsd on /proc/fs/nfsd type nfsd (rw)
    [root@turtle gaudetteje]#
    I'm grateful that you were able to discern why this was not working, but I fail to see how this causes the permission denied error to go away. Can you enlighten me?

    Thank you!

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    The light ;)

    First of all, sorry because my english is not ok.

    I had already bumped into this bug.

    This is an error that made me breaking the boss. With the error "permision denied", is impossible to solve the problem.


    Greetings!

  6. #6
    Just Joined!
    Join Date
    Aug 2007
    Posts
    1

    Big thanks

    Works just fine.10x a lot.
    Quote Originally Posted by whats View Post
    you can solve the problem adding the following lines in /etc/fstab on the server side:

    nfsd /proc/fs/nfsd nfsd auto,defaults 0 0
    sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs auto,defaults 0 0

    Then type on the server
    mount -a

    And try to mount de resource in the client

    --
    Albert Sellarès GPG id: 0xB88C621A
    wekk.net - "Person who say it cannot be done should not interrupt person doing it." whats_up@jabber.org
    Membre de Catux.org Catux - Portada
    Linux User: 324456 Catalunya

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •