Find the answer to your Linux question:
Results 1 to 5 of 5
I need help with basic network interface configuration on a vintage system. PC is a Gateway Pentium 60 MHz/64MB ram/2.1GB HD/3c509B-TPO. It's a former Win98 machine that I'm converting to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Location
    Caldwell, Idaho
    Posts
    4

    3c509b-TPO initial config prob under RH6


    I need help with basic network interface configuration on a vintage system. PC is a Gateway Pentium 60 MHz/64MB ram/2.1GB HD/3c509B-TPO. It's a former Win98 machine that I'm converting to Linux as a learning tool. I plan to use it for web mail and chat full time while I do 'real work' on another PC. May use it as a firewall learning platform.

    Regarding my current problem, yes, I have RTFM as best I know how. I've searched HOW-TOs, FAQs, Linux books I have and other web sites.

    I used the 3Com DOS utility to disable PnP and set the card to irq=10 io=0x210. Card passed all the utility's tests.

    Onto a 'blank' HD, I installed RH6 from the CD included with Sam's _Red Hat Linux 6 Unleashed_ -- mostly because I had it! (And, yes, I do plan to upgrade as far as my hardware will allow -- once I'm on the network.) During the install I used the Workstation option and the card was detected. The machine boots and runs just fine (perhaps a bit slow). During boot eth0 doesn't initialize -- [Failed] message.

    My home network includes a d-Link DI-514 4-port switch / router / wireless access point used to connect together two wired Win XP Pro boxes, a wireless Win XP Pro desktop, a wireless Win2K laptop and a DSL modem.

    The d-Link is running DHCP for the windows boxes. I hard wired into the d-Link this static IP address for the linux box using the 3c509's MAC addr:

    IP=192.168.0.101
    Netmask=255.255.255.0
    Gateway=192.168.0.1

    ifconfig -a shows only the lo loopback at 127.0.0.1, no eth0.

    dmesg shows no attempt to start eth0 -- nothing at all about eth0. These lines are there:

    Linux NET4.0 for Linus 2.2
    Based upon Swansea University Computer Society NET3.039
    NET4: Unix domain sockets 1.0 for Linux NET4.0.
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    Initializing RT netlink socket


    Again, using the book, I checked the settings in these files:
    /etc/sysconfig/network
    /etc/HOSTNAME
    /etc/hosts
    /etc/services
    /etc/host.conf
    /etc/nsswitch.conf
    /etc/resolv.conf

    All settings seemed to match what the book said to expect.

    The book also referred to a file /etc/init.d/network that was not on my system:

    IPADDR=192.168.0.101
    NETMASK=255.255.255.0
    NETWORK=192.168.0.0
    BROADCAST=192.168.0.255
    GATEWAY=192.168.0.1

    I added it and ran ../init.d/network restart, but it didn't change my results.

    From another site I got the info to add this line to the top of my lilo.conf file:

    ether=10,0x210,0,0x3c509,eth0

    I added it and just rebooted, it still didn't change my results.

    I can ping localhost, but can't ping the router, duh. For completeness I tried to ping .101 from the XP box with no joy.

    Obviously I'm a newbie here and to linux, but I am enthusiastic! In my efforts to get started I'm out of places to check/configure, but I suspect that there's probably a fairly simple solution to this question. I must have missed setting a value in some file...

    Thanks for any assistance anyone can provide!

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Did you do
    Code:
    modprobe 3c509
    ?
    The system may "recognise" the card, but it can't do anything until the driver is loaded. Check that it is loaded with 'lsmod' to list loaded modules. If it loads successfully, you should see eth0 when you do 'ifconfig'. Only then can you set the IP for eth0 and only then can you ping with it. I have that adapter in a 486 box running Slackware 8.1 and can get more info if you need it. The 'modprobe' command may need some other parameters, I'd have to check my system to see. Note that 3c509 is a 10Mbps card so it will be slower than the more common 100Mbps. If you can get it working, the module will need to be added in your boot procedure to get it to load automatically.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Location
    Caldwell, Idaho
    Posts
    4
    Using your suggestion I got to
    Code:
    insmod 3c509
    which got the module loaded, then
    Code:
    ../init.d/network restart
    got it initialized and running.

    I can now ping myself(!), the router, other PC on the LAN and IP addresses on the internet by IP or name.

    Next challenge: Netscape [4.51] in it's default config has Java enabled, but when I try to load a page with Java (like mail.yahoo.com) the message "Starting Java..." is displayed on the status bar at the bottom for a few seconds and then the browser closes. The Yahoo and Google home pages display just fine for comparison.

    I've got no problem with upgrading the browser. My first thought though was to get the box fully operational before making substantial changes. On the other hand, improvements in later browsers may speak to upgrading as a better choice.

    Yet another challenge is that I've never used rpm.

    Thanks for your modprobe suggestion, it was a major step forward.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Location
    Caldwell, Idaho
    Posts
    4
    oops!

    Forgot to say that I also don't know which script to change to get the 3c509 module loaded at boot so that I don't have to load and start it manually each time...

    Thanks.

  6. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by roboates
    Forgot to say that I also don't know which script to change to get the 3c509 module loaded at boot so that I don't have to load and start it manually each time...
    So why 'insmod' and not 'modprobe'? 'modprobe' checks for and deals with dependent modules as well as the one specified. may not make a difference, but 'modprobe' is recommended, I think.

    The script to add the 'modprobe' or 'insmod' command varies by distro and version. Does your system not have a graphical network setup utility? Check /etc/module.conf. Do 'apropos modules' to see a list of commands or files relating to modules for which man pages are available. Check init.d/network. Or you can write a bash script to do modprobe, ifconfig and network restart, each in turn and run that at the end of the init sequence. In Fedora Core 1, /etc/rc.d/rc.local exists for that purpose and I expect you have a similar file.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •