Find the answer to your Linux question:
Results 1 to 4 of 4
I have a linux server running fedora 3 and it has one wired ethernet card. I have eth0 setup so that it gets an IP address via my DHCP server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8

    Fedora forgetting network configurations


    I have a linux server running fedora 3 and it has one wired ethernet card.

    I have eth0 setup so that it gets an IP address via my DHCP server and I have eth0:0 setup so that it uses a static IP that I assigned. They both have config files in the /etc/sysconfig/network-scripts directory.

    Most of the time both addresses work fine. But leaving the machine alone for a while I will come back, or try to shell into the eth0:0 IP and it will not work. I will get in via the other port and when I run "ifconfig" it shows no eth0:0 running. (During this time the eth0 configuration always works fine. )

    To get it back I just run "ifup eth0:0" and then it works fine for a while until this all starts to happen again. Right now I'm solving the problem by running a cron job to start up the eth0:0 every 2 hours, but this is clearly not how I would prefer to solve this problem. Does any one have any idea why this could happen? Is my ethernet card going bad?

    Thanks.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    That's an odd problem. Does eth0 lose it's IP as well? Do you see anything about it in your /var/log/messages?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8
    Nope, eth0 (using DHCP) is always up and with the same address.

    I see a lot of DHCPRECQUESTs for eth0 but nothing that pertains to eth0:0.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8
    I tried inserting and setting up a second ethernet card. This will be a test to see if it drops out like the eth0:0 i set up before.

    ...unless anyone has a clue what is causing this problem?!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •