Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Originally Posted by jaboua Maybe yast does the trick for you? any more specifics? Which Yast module are you refering to? I haven't found one to manage mount points....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie pajamabama's Avatar
    Join Date
    Jul 2005
    Location
    In another time's forgotten space
    Posts
    150

    Quote Originally Posted by jaboua
    Maybe yast does the trick for you?
    any more specifics? Which Yast module are you refering to? I haven't found one to manage mount points.
    HP Pavilion dv6000t
    Intel Centrino Duo 2.0GHz
    nVidia GeForce Go 7400
    Fedora 10

    ----------------------
    The real question is what time is it and why the hell am I still screwing around with my computer?

  2. #12
    Just Joined! teraya's Avatar
    Join Date
    Jul 2006
    Location
    ATL
    Posts
    2
    You need "setuid" on the mount/umount.cifs files... (otherwise, only root can use them).

    [root@toreador ~]# which mount.cifs umount.cifs | xargs chmod -v u+s
    mode of `/sbin/mount.cifs' changed to 4755 (rwsr-xr-x)
    mode of `/sbin/umount.cifs' changed to 4755 (rwsr-xr-x)

  3. #13
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2

    mount error 1 - also looked and looked

    I looked for quite a while to solve this as well and found this link:

    http://www.bobpeers.com/linux/mount

    Look to the bottom. It seems users my no longer mount with mount.cifs. Do we agree? Kind of a bummer.

    -EDIT-

    I saw the 2nd page and the post before mine after adding my post. I decided to try the suggestion:

    [root@core5 sbin]# chmod -v u+s mount.cifs umount.cifs
    mode of `mount.cifs' changed to 4755 (rwsr-xr-x)
    mode of `umount.cifs' changed to 4755 (rwsr-xr-x)

    It didn't seem to work so I decided to go back to original state:

    [root@core5 sbin]# chmod -v u-s mount.cifs umount.cifs
    mode of `mount.cifs' changed to 0755 (rwxr-xr-x)
    mode of `umount.cifs' changed to 0755 (rwxr-xr-x)

    Now i can't mount at all and get this error:

    [root@core5 sbin]# mount //datalognote/data
    retrying with upper case share name
    mount error 6 = No such device or address
    Refer to the mount.cifs( manual page (e.g.man mount.cifs)

    Now it's a real bummer, any ideas?

  4. #14
    Just Joined! teraya's Avatar
    Join Date
    Jul 2006
    Location
    ATL
    Posts
    2

    Question need more info

    In order to help you, please post the results of these commands...

    cat /etc/fstab

    smbclient -L //datalognote

    (If your fstab contains your password, remember to xxxxx it out when you post it here).

  5. #15
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2

    partly my bad

    Thank you very much for returning my post, very kind.

    This was partly my bad and now not such a bummer, but the user running the command still exists, maybe also me.

    The share name on the XP machine had a character appended to it yeilding the error 6. So I retried the commands you posted:

    [root@core5 ~]# chmod -v u+s /sbin/mount.cifs /sbin/umount.cifs
    mode of `/sbin/mount.cifs' changed to 4755 (rwsr-xr-x)
    mode of `/sbin/umount.cifs' changed to 4755 (rwsr-xr-x)


    The result to the user was:

    [pault@core5 /]$ mount /mnt/note
    mount: only root can mount //datalognote/data on /mnt/note


    is not fact that filetype cifs in fstab is suppose to invoke mount.cifs? man page snip:

    'It is usually invoked indirectly by the mount( command when using the "-t cifs" option.'

    maybe it's only from the command line?

    Here is the data you asked for from an otherwise working config:

    [root@core5 ~]# smbclient -L //datalognote
    Password:
    Domain=[DATALOGNOTE] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

    Sharename Type Comment
    --------- ---- -------
    IPC$ IPC Remote IPC
    SharedDocs Disk
    Data Disk
    Downloads Disk
    Domain=[DATALOGNOTE] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

    Server Comment
    --------- -------

    Workgroup Master
    --------- -------
    [root@core5 ~]#
    [root@core5 ~]#
    [root@core5 ~]# cat /etc/fstab
    /dev/VolGroup00/LogVol00 / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    //datalognote/data /mnt/note cifs rw,noauto,username=pault,password=addyourown,uid=5 00,gid=500 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0


    Thank you again for your time and response.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •