Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I've got the following line in my fstab: Code: //bullwinkle/scolgan /home/sean/CSMEG_scolgan cifs noauto,user,sync,username=scolgan%<my_password>,uid=sean,gid=users,file_mod=0755,dir_mode=0755 0 0 This is to mount a W2K3 server share. This is on a laptop so I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie pajamabama's Avatar
    Join Date
    Jul 2005
    Location
    In another time's forgotten space
    Posts
    150

    'user' option in fstab


    I've got the following line in my fstab:

    Code:
    //bullwinkle/scolgan	/home/sean/CSMEG_scolgan	cifs   noauto,user,sync,username=scolgan%<my_password>,uid=sean,gid=users,file_mod=0755,dir_mode=0755	0 0
    This is to mount a W2K3 server share. This is on a laptop so I'm not always connected to that network, thus the 'noauto' (use of 'auto' would probably obviate this issue).

    I've also included the 'user' option. This is supposed to let me mount this share as a user correct? For some reason this is not the case. I must su- root first.

    This is the error I get as a user:

    Code:
    sean@Iago&#58;~> mount /home/sean/CSMEG_scolgan/
    mount error 1 = Operation not permitted
    Refer to the mount.cifs&#40;8&#41; manual page &#40;e.g.man mount.cifs&#41;
    My guess is that this is because 'user' is also an option for mount.cifs and it's somehow being applied to that instead. I'm using the 'username' option for cifs to try to resolve this but, as you can see, no love.

    Anyone have any thoughts on this?
    HP Pavilion dv6000t
    Intel Centrino Duo 2.0GHz
    nVidia GeForce Go 7400
    Fedora 10

    ----------------------
    The real question is what time is it and why the hell am I still screwing around with my computer?

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Try using "users" instead of "user". The only differense is that all users can umount it again and such.

  3. #3
    Linux Newbie pajamabama's Avatar
    Join Date
    Jul 2005
    Location
    In another time's forgotten space
    Posts
    150
    so I replaced the 'user' option in fstab with 'users'. Here's the fstab entry now:
    Code:
    //bullwinkle/scolgan	/home/sean/CSMEG_scolgan	cifs	noauto,users,sync,username=scolgan%<my_password>,uid=sean,gid=users,file_mod=0755,dir_mode=0755	0 0
    now I'm getting a new problem:
    Code:
    sean@Iago&#58;~> mount /home/sean/CSMEG_scolgan/
    username specified with no parameter
    which I'm getting for both users and root. so it's fixed the permission issue I guess but maybe is still getting confused by the 'users' & 'username' options?
    HP Pavilion dv6000t
    Intel Centrino Duo 2.0GHz
    nVidia GeForce Go 7400
    Fedora 10

    ----------------------
    The real question is what time is it and why the hell am I still screwing around with my computer?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Try without the UID and GID options, if your user mount it, then it will probably be mounted with that owner as well.

  6. #5
    Banned CodeRoot's Avatar
    Join Date
    Sep 2005
    Posts
    567
    Try 'user=' instead of 'username='.
    Also, 'file_mod=' -> 'file_mode='.

  7. #6
    Linux Newbie pajamabama's Avatar
    Join Date
    Jul 2005
    Location
    In another time's forgotten space
    Posts
    150
    Is there a way of loading changes to the fstab without restarting?
    HP Pavilion dv6000t
    Intel Centrino Duo 2.0GHz
    nVidia GeForce Go 7400
    Fedora 10

    ----------------------
    The real question is what time is it and why the hell am I still screwing around with my computer?

  8. #7
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Quote Originally Posted by pajamabama
    Is there a way of loading changes to the fstab without restarting?
    umount the partition you changed entry for

    run "mount -a"

  9. #8
    Banned CodeRoot's Avatar
    Join Date
    Sep 2005
    Posts
    567
    The 'noauto' option will render "mount -a" ineffective for that device.

    Suggestion:

    Execute: umount /home/sean/CSMEG_scolgan/
    Edit fstab and save.
    Execute: mount /home/sean/CSMEG_scolgan/

    NOTES:

    From the mount.cifs man-page:

    user=arg
    specifies the username to connect as. If this is not given, then the environment variable USER is used. This option can also take the form "user%password" or "user/workgroup" or "user/workgroup%password" to allow the password and workgroup to be specified as part of the user name.

    Cifsfs has the parameter user=, not username=, like smbfs.
    (Emphasis mine.)

    'user' and 'user=' should both be usable together. Try placing the 'cifs' options first, followed by the standard mount options.

  10. #9
    Linux Newbie pajamabama's Avatar
    Join Date
    Jul 2005
    Location
    In another time's forgotten space
    Posts
    150
    I've tried both the 'user' and 'username' options for cifs. The 'username' option is still valid, I believe, for backwards compatability. I tried 'username' because I thought that might aleveiate the confusion with the mount 'user' option. So far though, nothing seems to have solved it.

    It's not a big deal, because I can just su- root to mount the share. But gosh-drat-it, I want this thing to work like it's supposed to.
    HP Pavilion dv6000t
    Intel Centrino Duo 2.0GHz
    nVidia GeForce Go 7400
    Fedora 10

    ----------------------
    The real question is what time is it and why the hell am I still screwing around with my computer?

  11. #10
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Maybe yast does the trick for you?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •