Find the answer to your Linux question:
Results 1 to 7 of 7
i have a linksys wrt54g router.. and an hp ze4927ea.. redhat linux enterprise 4 ws i have installed the latest version of ndiswrapper.. installed the correct drivers.. got my wifi ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    wireless not working


    i have a linksys wrt54g router.. and an hp ze4927ea.. redhat linux enterprise 4 ws

    i have installed the latest version of ndiswrapper.. installed the correct drivers.. got my wifi card working (yes got the light up) after updating my linux kernel to support the 16k stacks and disabling the acpi..

    now my problem is i get access provider (AP) on doing "iwlist wlan0 scan"

    on doing the remaining configuration steps i get everything correct in the command "iwconfig wlan0" but still i am unable to connect to the internet..

    the router is setup in WEP mode .. (yes i configure wlan0 for wep) ..

    now if somebody is familiar with Kwifimanager in redhat it shows the correct configuration specified but in the bottom left hand side of the box it says AP : UNKNOWN.. whereas in its main window it states the correct Hardware address of the access provider..

    now i am fairly new to linux and this problem has stumped me for almost 2 days.. any help will be really appreciated

    thanx in advance

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    @ ameyap
    whats the result from the iwconfig command? and also the ifconfig command?
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    here r the messages

    Code:
    [root@localhost ~]# ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:C0:9F:49:2A:EC
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 b)  TX bytes:238 (238.0 b)
              Interrupt:10 Base address:0x3000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2364 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2364 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:2107266 (2.0 MiB)  TX bytes:2107266 (2.0 MiB)
    
    sit0      Link encap:IPv6-in-IPv4
              NOARP  MTU:1480  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    wlan0     Link encap:Ethernet  HWaddr 00:0E:35:4C:50:A4
              inet6 addr: fe80::20e:35ff:fe4c:50a4/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:17 errors:0 dropped:0 overruns:0 frame:0
              TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:6041 (5.8 KiB)  TX bytes:0 (0.0 b)
              Memory:e0204000-e0204fff
    ------------------------------------------------------------------------
    Code:
    [root@localhost ~]# iwconfig wlan0
    Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
    but has been compiled with version 16, therefore some driver features
    may not be available...
    
    wlan0     IEEE 802.11g  ESSID:"AmeyaLink"  Nickname:"localhost.localdomain"
              Mode:Managed  Frequency:2.437GHz  Access Point: 00:14:BF:04:9E:00
              Bit Rate=54Mb/s
              RTS thr=1600 B   Fragment thr=2304 B
              Encryption key:XXXX-XXXX-XX   Security mode:restricted
              Power Management:off
              Link Quality:0/100  Signal level:-59 dBm  Noise level:-256 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    -------------------------------------------------------------------------------
    Code:
    [root@localhost ~]# iwlist wlan0 scan
    Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
    but has been compiled with version 16, therefore some driver features
    may not be available...
    
    wlan0     Scan completed :
              Cell 01 - Address: 00:14:BF:04:9E:00
                        ESSID:""
                        Protocol:IEEE 802.11g
                        Mode:Managed
                        Frequency:2.437GHz (Channel 6)
                        Quality:0/100  Signal level:-56 dBm  Noise level:-256 dBm
                        Encryption key:on
                        Bit Rate:1Mb/s
                        Bit Rate:2Mb/s
                        Bit Rate:5.5Mb/s
                        Bit Rate:11Mb/s
                        Bit Rate:18Mb/s
                        Bit Rate:24Mb/s
                        Bit Rate:36Mb/s
                        Bit Rate:54Mb/s
                        Bit Rate:6Mb/s
                        Bit Rate:9Mb/s
                        Bit Rate:12Mb/s
                        Bit Rate:48Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0
              Cell 02 - Address: 00:14:BF:04:9E:00
                        ESSID:"AmeyaLink"
                        Protocol:IEEE 802.11g
                        Mode:Managed
                        Frequency:2.437GHz (Channel 6)
                        Quality:0/100  Signal level:-57 dBm  Noise level:-256 dBm
                        Encryption key:on
                        Bit Rate:1Mb/s
                        Bit Rate:2Mb/s
                        Bit Rate:5.5Mb/s
                        Bit Rate:11Mb/s
                        Bit Rate:18Mb/s
                        Bit Rate:24Mb/s
                        Bit Rate:36Mb/s
                        Bit Rate:54Mb/s
                        Bit Rate:6Mb/s
                        Bit Rate:9Mb/s
                        Bit Rate:12Mb/s
                        Bit Rate:48Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0
    --------------------------------------------------------------------------------
    Code:
    [root@localhost ~]# dmesg
    ...........
    ndiswrapper version 1.4 loaded (preempt=no,smp=no)
    ndiswrapper: driver w22n51 (Intel,03/08/2004,8.0.12.20000) loaded
    PCI: Found IRQ 11 for device 0000:02:06.0
    PCI: Sharing IRQ 11 with 0000:00:1f.1
    ndiswrapper: using irq 11
    ndiswrapper (ExFreePool:1030): wrong tag: 4261412863 (e96ebc1c)
    ndiswrapper (ExFreePool:1030): wrong tag: 4294967295 (e96ebc18)
    ndiswrapper (ExFreePool:1030): wrong tag: 4294967295 (e96ebc14)
    ndiswrapper (ExFreePool:1030): wrong tag: 4294967295 (e96ebc10)
    divert: allocating divert_blk for wlan0
    wlan0: vendor: 'Intel(R) PRO/Wireless 2200 LAN Card Driver'
    wlan0: ndiswrapper ethernet device 00:0e:35:4c:50:a4 using driver w22n51, 8086:4220:103C:12F6.5.conf
    wlan0: encryption modes supported: WEP; TKIP with WPA
    ndiswrapper (set_packet_filter:563): couldn't set packet filter: C00000BB
    ndiswrapper (set_multicast_list:698): couldn't set packet filter (C00000BB)
    ndiswrapper (set_packet_filter:563): couldn't set packet filter: C00000BB
    ndiswrapper (set_multicast_list:698): couldn't set packet filter (C00000BB)
    ndiswrapper (set_packet_filter:563): couldn't set packet filter: C00000BB
    ndiswrapper (set_multicast_list:698): couldn't set packet filter (C00000BB)
    ndiswrapper (set_packet_filter:563): couldn't set packet filter: C00000BB
    ndiswrapper (set_multicast_list:698): couldn't set packet filter (C00000BB)
    ndiswrapper (set_packet_filter:563): couldn't set packet filter: C00000BB
    ndiswrapper (set_multicast_list:698): couldn't set packet filter (C00000BB)
    ndiswrapper (update_wireless_stats:1290): statistics disabled for wlan0
    wlan0: no IPv6 routers present
    ndiswrapper (set_packet_filter:563): couldn't set packet filter: C00000BB
    ndiswrapper (set_multicast_list:698): couldn't set packet filter (C00000BB)
    ndiswrapper (wrapper_worker_proc:1365): wlan0 is being reset
    ndiswrapper (wrapper_worker_proc:1365): wlan0 is being reset
    ndiswrapper (wrapper_worker_proc:1365): wlan0 is being reset
    ndiswrapper (wrapper_worker_proc:1365): wlan0 is being reset
    ndiswrapper (wrapper_worker_proc:1365): wlan0 is being reset
    any help would be greatly apreciated

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    hello...

    another thing my router is set is broadcast off mode.. that means it doesn't broadcast the essid..

    and anoher thing is there seems to be some irq conflict between ndiswrapper and ehci_hcd... now as stated earlier i have put the params acpi=noirq in the linux startup.. but it doesn't seem to be working

    here is another output
    Code:
    [root@localhost ~]# cat /proc/interrupts
               CPU0
      0:     642855          XT-PIC  timer
      1:        913          XT-PIC  i8042
      2:          0          XT-PIC  cascade
      5:         11          XT-PIC  Intel ICH4 (24C5)
      8:          1          XT-PIC  rtc
      9:         82          XT-PIC  acpi
     10:          3          XT-PIC  uhci_hcd, i915@pci:0000:00:02.0
     11:        500          XT-PIC  ehci_hcd, uhci_hcd, yenta, ndiswrapper
     12:     123060          XT-PIC  i8042
     14:      17892          XT-PIC  ide0
     15:       5273          XT-PIC  ide1
    NMI:          0
    ERR:          0
    notice the ndiswrapper under 11..
    well half the times theres a conflict between ndiswrapper and my enhanced usb.. when that happens the wifi card fails to light up and i am forced to restart linux and hope there is no conflict.. even now i order to paste the above outputs i had to restart linux 2 times.. i think this is really funny/odd.. any solutions to the above problem..

    here is the dmesg output when this happens
    Code:
    ....
    ndiswrapper version 1.4 loaded (preempt=no,smp=no)
    atkbd.c: Unknown key pressed (translated set 2, code 0xf8 on isa0060/serio0).
    atkbd.c&#58; Use 'setkeycodes e078 <keycode>' to make it known.
    ipw2200&#58; ipw-2.2-boot.fw load failed&#58; Reason -2
    ipw2200&#58; Unable to load firmware&#58; 0xFFFFFFFE
    ipw2200&#58; Failed to up device
    atkbd.c&#58; Unknown key released &#40;translated set 2, code 0xf8 on isa0060/serio0&#41;.
    atkbd.c&#58; Use 'setkeycodes e078 <keycode>' to make it known.
    atkbd.c&#58; Unknown key pressed &#40;translated set 2, code 0xf8 on isa0060/serio0&#41;.
    atkbd.c&#58; Use 'setkeycodes e078 <keycode>' to make it known.
    atkbd.c&#58; Unknown key released &#40;translated set 2, code 0xf8 on isa0060/serio0&#41;.
    atkbd.c&#58; Use 'setkeycodes e078 <keycode>' to make it known.
    atkbd.c&#58; Unknown key pressed &#40;translated set 2, code 0xf8 on isa0060/serio0&#41;.
    atkbd.c&#58; Use 'setkeycodes e078 <keycode>' to make it known.
    atkbd.c&#58; Unknown key released &#40;translated set 2, code 0xf8 on isa0060/serio0&#41;.
    atkbd.c&#58; Use 'setkeycodes e078 <keycode>' to make it known.
    note the unknownkey pressed and released is when i am pressing the wifi on /off button

    whats happening????

    thanx in advance

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Code:
    wlan0&#58; vendor&#58; 'Intel&#40;R&#41; PRO/Wireless 2200 LAN Card Driver'
    wlan0&#58; ndiswrapper ethernet device 00&#58;0e&#58;35&#58;4c&#58;50&#58;a4 using driver w22n51, 8086&#58;4220&#58;103C&#58;12F6.5.conf
    wlan0&#58; encryption modes supported&#58; WEP; TKIP with WPA
    One thing I don't get is why it is using the ipw windows drivers for your card. Your card seems to be connected and everything, but the ndiswrapper error are the first of its kind that i have seen. Hmm, i'd suggest some googling on your part, and i'll try and do the same.
    Life is complex, it has a real part and an imaginary part.

  7. #6
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    ipw drivers

    i followed the steps exactly as mentioned on the ndiswrapper site and installed the drivers that they recommended in their card list .. earlier i had tried installing the drivers on my cd but after installation the card light was not coming up.. but i think now this could be due to the irq conflict.. i will remove the current drivers and reinstall my cd drivers just to be sure..

  8. #7
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    Thread split of another wireless thread
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •