Find the answer to your Linux question:
Results 1 to 4 of 4
My router recently got knocked out by an outage from my ISP. Since then I've haven't got it back up and running. So in the meantime, I've changed my eth0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496

    DHCP Help


    My router recently got knocked out by an outage from my ISP. Since then I've haven't got it back up and running. So in the meantime, I've changed my eth0 to use DHCP and hit the net directly.
    The problem is that after restarting the machine, I have to manually drop to a term window and issue
    Code:
    # dhcpcd eth0
    My /etc/conf.d/net has the following in it:
    Code:
    # /etc/conf.d/net:
    # $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/net,v 1.7 2002/11/18 $
    
    # Global config file for net.* rc-scripts
    
    # This is basically the ifconfig argument without the ifconfig $iface
    #iface_eth0="192.168.128.2 broadcast 192.168.128.255 netmask 255.255.255.0"
    #iface_eth1="207.170.82.202 broadcast 207.0.255.255 netmask 255.255.0.0"
    
    # For DHCP set iface_eth? to "dhcp"
    # For passing options to dhcpcd use dhcpcd_eth?
    #
    iface_eth0="dhcp"
    #dhcpcd_eth0="..."
    Any help on how to have this use dhcp automagically? BTW, I'm on Gentoo if that makes a difference.

    TIA,
    CT
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Make sure that dhcpd is started at boot, as well.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    does gentoo have an rc.local file?

    if so, you could put "dhcpcd eth0" in there.

    Jason

  4. #4
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    I added
    Code:
    dhcpcd eth0
    to my /etc/rc.conf file and all is good now.

    Thanks so much!
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •