Find the answer to your Linux question:
Results 1 to 2 of 2
I'm having a problem with internet connection sharing. Every time I restart the network, my resolv.conf gets overwritten by dhcp. Because of that, my second computer can't access the internet. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Location
    Belgium
    Posts
    22

    resolv.conf problem


    I'm having a problem with internet connection sharing. Every time I restart the network, my resolv.conf gets overwritten by dhcp. Because of that, my second computer can't access the internet.

    It's only eth1 that gets his IP from dhcp (dhcp on adslmodem). eth0 (connection to the second computer) has a static IP.

    How do I prevent this overwriting to happen?
    Setting a static IP for eth1 I guess, but I kinda messed it up the last time I tried

    I'm running Fedora Core 4, but I can only use command line

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    In your /etc/rc.local, add this line at the bottom.
    echo "nameserver YOUR_DNS_IP_HERE" > /etc/resolv.conf
    I think that would do it
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •