Find the answer to your Linux question:
Results 1 to 2 of 2
hi, i use archlinux 0.7.1 on amd athlon xp here is what i did: i followed the wiki http://wiki.archlinux.org/index.php/NTP to set up ntp then i installed the package ntp with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    Los Angeles
    Posts
    4

    HELP please, no networking


    hi,
    i use archlinux 0.7.1 on amd athlon xp
    here is what i did:
    i followed the wiki http://wiki.archlinux.org/index.php/NTP to set up ntp
    then i installed the package ntp with pacman and i guess that overrode the ntp.conf file. anyhow, after reboot networking fails. can anybody advise me?

    here are some files and logs:

    /etc/ntp.conf :
    http://rafb.net/paste/results/1eZ3nK86.html

    ntp.log :
    http://rafb.net/paste/results/j8OLrL45.html

    /etc/rc.conf :
    http://rafb.net/paste/results/4fBFLQ74.html

    syslog.log :
    http://rafb.net/paste/results/0VZgiO.../j8OLrL45.html

  2. #2
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    723

    Try this

    I've never used archlinux, but I think I can see the problem.

    NTP should not affect the network setup, but in your rc.conf you have the following entry:

    Code:
    #
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   (prefix a route in ROUTES with a ! to disable it)
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(!gateway)
    Which defines your default gateway as 192.168.0.1 (probably correct) but then disables it (!gateway)

    You shouldn't need to specify the gateway at all because eth0 is configured to use dhcp

    Code:
    eth0="dhcp"
    INTERFACES=(lo eth0)
    so you should be able to comment out the gateway and the ROUTES lines and restart the network. If that doesn't work then uncomment those lines and remove the exclamation mark from the gateway entry.

    Code:
    ROUTES=(gateway)
    If that doesn't work, could you provide us with the output of "route", "ifconfig -a" and "cat /etc/resolv.conf"

    Hope that helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •