Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Pinging still results in an unknown host error. Route, oddly enough returned this: Code: Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.1.0 * 255.255.255.0 U ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Nov 2005
    Location
    New York City
    Posts
    7

    Pinging still results in an unknown host error. Route, oddly enough returned this:

    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    link-local      *               255.255.0.0     U     0      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
    Even though I entered the routing information. I just went back to routing and it shows up in the Routing Table under my wireless card, with the device set for wlan0 and all of it. o.O?

  2. #12
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Hmm, only other thing i can think of is to do this, goto the place you configured the wired card. Under hardware, tell the system to bring up the wired card manually. Now goto the wireless card, tell the system to bring up the card on boot. Save the settings, pull the cable from the wired card. Also make sure that wireless settings are correct.

    Now reboot the system.
    Life is complex, it has a real part and an imaginary part.

  3. #13
    Just Joined!
    Join Date
    Nov 2005
    Location
    New York City
    Posts
    7
    Okay, now I feel a little silly.

    I tried what you said, and it didn't work. But I went back and checked the settings once again and finally notice that I had messed up the encyption passkey. Alright, still no internet, I still can't ping. But, KWifiManager now says

    Connected to Network: myNetwork
    Access Point: a:Mac:address
    Local IP: 192.168.1.106

    Which is more than it did before. An additional plus: I can connect to my router. Going to 192.168.1.1 now brings me to my router's configuration panel, just like with windows or when I have the wire plugged into this linux box. But no internet yet.

    Almost there! Thank you for all you've done so far!

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    what does ping give you now? Also, since you are using SUSE, KInternet is the thing youshould be using to check wether the card is connected and everything. The KInternet icon is the one in the taskbar near the clock which looks like two plugs connected together.

    When you ping, ping with this:
    Code:
    ping -c 4 -I wlan0 www.google.com
    thats a - I (Capital i).

    Also try pinging based on ip addresses and not hostnames, e.g. use 66.102.7.99 for google
    Life is complex, it has a real part and an imaginary part.

  6. #15
    Just Joined!
    Join Date
    Nov 2005
    Posts
    1
    I had the same problem. What worked for me was simply disabling your ethernet card and giving it a static IP address. Then the wireless card worked. Don't ask me why, but hopefully enjoy too!

    Erwin.

  7. #16
    Just Joined!
    Join Date
    Jan 2006
    Posts
    1
    i had the same problem with my netgear router/card. i did all the stuff that was mentioned in the forum, then realized that I didnt add my card to the access list in my router. /me is an idiot. You might want to check into that with your router.

  8. #17
    Just Joined!
    Join Date
    Jan 2005
    Posts
    2

    Same problem

    I have the same problem: Wireless works but the DHCP client only retrieves local subnet information. Default route and DNS server settings are not imported from the DHCP server. The only workaround I have found is to manually add the respective settings: Put the router's IP in /etc/resolv.conf and at the same time use it as default gateway.

    With regard to diagnostics, the bug seems to be a tricky one:

    - I have a dual boot notebook and I only experience the symptoms mentioned if I boot Linux. Windoze works perfectly.

    - BUT: The problem only persists at home (or friends' home) where typical home users' wireless routers are in place (Siemens, Netgear, US-Robotics). Whenever I work in professional environments (Airports, Corporate Wireless), also Linux works like a dream and retrieves all the DHCP settings (incl. default route and DHCP)

    => Seems to be quite an unlucky interaction between the Linux DHCP client on the one and "home use" routers on the other side. Maybe worth being checked by some SuSE folks...

    Best regards
    Axel

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •