I've got a D-Link DFM 560E external modem on an up to date system.
My modem supports up to K56Flex and V.90 (Also v.42bis and v.42, ...)
My dial-up connection is slow, but too slow with 1 special ISP.
I tried on both Linux and M$ Windows.
There is no problem with ISPs. Because there is another PC beside PC of mine which has got an internal winmodem and has no speed problem. Thus I guess the problem is with my modem (or COM port !!!???).
Three nice phenomena about my strange modem/dial-up:

( 1 ) When I connect to the trouble-maker ISP at 24000 the speed is GREAT!!!
( 2 ) Using a good proxy speeds me up a little.
( 3 ) My modem give ERROR is response to AT+MS=X,X,X,X command!!! I tried with many trusted values.

I tried my modem with the OK PC and the result was exciting: a GREAT speed!
The only change I made was that I plugged out the serial cable of my modem from my PC and plugged it into the other PC. The line and every other parameter is the same.

Now what is causing this problem?

My system is:
AMD Athlon64 3000+ 1800MHz @ 2100MHz
MB: MSI Neo2-FX (7025) LAN 1000Mb/s onboard
RAM: 512 MB