Find the answer to your Linux question:
Results 1 to 6 of 6
After combing the internet constantly for over a day, I have found no solution for getting a WUSB54GS to work on Ubuntu (which I am pretty sure is Debian-based). I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    3

    Linksys WUSB54GS won't work with ndiswrapper


    After combing the internet constantly for over a day, I have found no solution for getting a WUSB54GS to work on Ubuntu (which I am pretty sure is Debian-based). I tried different versions of drivers for the card with ndiswrapper but have had no luck--mostly I get messages saying that the driver's *.conf doesn't exist when I try to modify that file, and the wusb54gs driver is labeled as invalid. No other driver I have tried has worked....so please help, if you are able to.

  2. #2
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    Did you try unplugging it, loading the .inf file and plugging it back in? Also I found that restarting my computer worked for some reason. Also, be sure you're not using the drivers off the cd that came with it, they never work.

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    3
    No, I haven't been using the files on the CD because there isn't a single .inf file other than the AUTORUN.inf, which does nothing. I suppose that it would make sense for you to unplug the device, then plug it in after loading the .inf file, because that's what it has you do in WinXP.

    Hopefully that will solve the problem of the missing *.conf file....do I really need this? Because when I try to edit it for the WUSB54GS, I just get a bash and cat error saying that the file doesn't exist (which I checked and found that it really doesn't exist).

    Thanks though, I'll be sure to try that.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2006
    Posts
    3
    Hmm....Well, I tried what you did, and the driver is still called invalid. For some reason it fixed the problem regarding the missing *.conf file...but still no luck with the internet. Perhaps I'm missing some files or using the wrong driver...though, the thing is, I tried both the v1 and v2 drivers from the Linksys website on Windows, and not much luck there..maybe you have to reboot after you uninstall one driver in order to install a newer one; I never bothered to check for driver updates before, so I guess I'm a bit behind. Would you mind sending me the files that worked for you in Linux (dazhboh@gmail.com) (assuming you check back here, of course...)? Also, at what point exactly did you plug the adapter back in? right after the ndiswrapper -i command? Feel free to further enlighten me.

  6. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1
    Can anybody please upload the .inf and the .conf file? or find a link for it?

  7. #6
    Linux Newbie
    Join Date
    Sep 2004
    Location
    Aberdeen, Scotland
    Posts
    204
    If its the version 1 you have follow instructions here https://help.ubuntu.com/community/Wi...CardsSupported . Make sure you have all files eg. *.inf, *.sys, *.bin in the same location when you ndiswrapper -i
    Elive,kanotix-mini,pclinuxos super gamer,xp, sidux

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •