Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am having a problem with the users I create on Suse 10.0 not working on Samba. It is my understanding that simply creating users in the YaST2 control center ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13

    Samba on SUSE 10.0


    I am having a problem with the users I create on Suse 10.0 not working on Samba. It is my understanding that simply creating users in the YaST2 control center creates those users as samba users as well. So why don't any of the users I make work except for the root user? am I missing something? am I completely wrong about how this works?

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    did you create samba passwords for those users? i.e. smbpasswd -a user_name
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13
    I ran that command successfully, then tried to login with no luck.

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    what does your /etc/samba/smb.conf file look like?
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13
    This is my smb.conf file. My understanding is that in Suse 10.0 any local users that you create are supposed exist as samba uses also. If this is not so then I need to figure out a way to setup a user friendly administration interface of some kind. I can handle CLI administration, but my boss will not find it acceptable.




    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2006/01/12 14:23:34

    [global]
    workgroup = SUSE-TEST
    map to guest = Bad User
    printcap name = cups
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    logon path = \\%L\profiles\.msprofile
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    domain logons = Yes
    os level = 65
    preferred master = Yes
    domain master = Yes
    cups options = raw
    include = /etc/samba/dhcp.conf


    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    create mask = 0600
    directory mask = 0700
    store dos attributes = Yes

    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes

    [printers]
    comment = All Printers
    path = /var/tmp
    create mask = 0600
    printable = Yes
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin, root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [netlogon]
    comment = Network Logon Service
    path = /var/lib/samba/netlogon
    write list = root

    [public]
    comment = publich share
    path = /samba shares/public/
    read only = No
    inherit acls = Yes

    [accounting]
    comment = accounting department folder
    path = /samba shares/accounting/
    read only = No
    inherit acls = Yes

    [communications]
    comment = communications department share
    path = /samba shares/communications/
    read only = No
    inherit acls = Yes

    [operations]
    comment = operations department share
    path = /samba shares/operations/
    read only = No
    inherit acls = Yes

    [tech]
    comment = IT department share
    path = /samba shares/tech/
    read only = No
    inherit acls = Yes

  6. #6
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13
    I am wondering if perhaps what I need to do is add the following to my smb.conf file




    # sync smb passwords woth linux passwords
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    passwd chat debug = yes
    unix password sync = yes



    I found this on a tutorial for setting up Ubuntu with Samba

  7. #7
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    What type of authentication are you using? The ideal case for your scenario is User authentication, instead of Share. Check your authentication scheme. This is what troubled me in the past.

  8. #8
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13
    My security is set to "USER" I assume that this controls the authentication method, there is also the option of share, server, domain, and ADS. I understand share, I'm guessing that domain references a different server for authentication and that ADS refers to active directory services. As for "SERVER" I have no idea what that means, LDAP?

    I am getting all of this information from SWAT by the way, perhaps there is something I can do from inside SWAT to reference my local users as valid samba users?

    I am willing to change to any other free distro as well as try add-on tools. I am currently trying to get Idealx up and running.

  9. #9
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try adding the following to the globals section of smb.conf:

    encrypt passwords = yes
    smb passwd file = /var/lib/samba/private/smbpasswd
    make sure that the /var/lib/samba/private/smbpasswd file exists before setting this option.
    Life is complex, it has a real part and an imaginary part.

  10. #10
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13
    I have added the global variables that you suggested. What exactly should this for my problem?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •