Find the answer to your Linux question:
Results 1 to 3 of 3
Forum n00b, anyway... Linksys wireless card installed the drivers using rpm installation of drivers from www.linuxant.com KWiFiManager says the card works and detects the network YaST lets me configure the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    2

    Wireless Card IP nightmare


    Forum n00b, anyway...

    Linksys wireless card

    installed the drivers using rpm installation of drivers from www.linuxant.com

    KWiFiManager says the card works and detects the network
    YaST lets me configure the card for DHCP or static

    but

    "Local IP: unavailible"

    I ran iwspy <my wireless card> <IP address of my router> and it returned
    something along the lines of IP address not working with DHCP

    I setup a static IP for my card, using default subnet masks and DNS servers

    iwspy " " returns failed

    tried to simply ping the router

    also failed

    The router recognizes my compy's MAC address, but not the IP address I assigned it statically.

    I have 20 days until this 30 day trial license is up. I'd like to get this resolved before then.

    Any help would be a god-send.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    I haven't used linuxant's driverloader software, but your problem may stem from the fact that the driver is not properly loaded or the incorrect driver is being used. What does iwconfig return? Also have you setup any encryption correctly?

    A cheap fix would be to try installing ndiswrapper as it is free and doesn't come with the restrictions of linuxant's software. To install ndiswrapper, launch yast -> "Install and remove software" and search for ndiswrapper. Now copy yuor WinXP drivers to your home directory and execute the following in terminal:
    Code:
    su -   <--- become root
    cd /home/your_username/drivers <--- where you saved the drivers
    ndiswrapper -i driver_name.inf
    ndiswrapper -l  <-- should return driver present, hardware present
    ndiswrapper -m
    modprobe ndiswrapper
    Now launch yast and under hardware details, enter ndiswrapper for the driver name and configure the card as normal.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    2

    works

    Well, since I'm in SuSE linux now, I guess it works

    I wonder why the linuxant software didn't work...oh well, I don't have to pay for anything then.

    thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •