Find the answer to your Linux question:
Results 1 to 4 of 4
Hi folks, FC3 Mozilla Firefox Standard firewall - Iptable My workstation is connected to 1.5Mb ADSL broadband. Recently on browsing Internet it takes a considerable time connecting websites. It did ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804

    Slow connection to Internet


    Hi folks,

    FC3
    Mozilla Firefox
    Standard firewall - Iptable

    My workstation is connected to 1.5Mb ADSL broadband. Recently on browsing Internet it takes a considerable time connecting websites. It did not happen in the past. I contacted the ISP reporting this problem. After checking the network he requested me taking following measures;

    1) ping website checking whether there are package losses
    2) disable auto dectect settings
    3) reduce cache to 30Mb

    Hereinunder are the results
    1) # ping -c 25 yahoo.com
    Code:
    PING yahoo.com (216.109.112.135) 56(84) bytes of data.
    .....
    ......
    --- yahoo.com ping statistics ---
    25 packets transmitted, 25 received, 0% packet loss, time 31926ms
    rtt min/avg/max/mdev = 298.039/303.828/309.182/3.021 ms, pipe 2
    # ping -c 25 google.com
    Code:
    PING google.com (64.233.167.99) 56(84) bytes of data.
    ...
    ....
    --- google.com ping statistics ---
    25 packets transmitted, 25 received, 0% packet loss, time 28713ms
    rtt min/avg/max/mdev = 265.137/267.465/270.636/1.427 ms, pipe 2
    No packet loss found.

    2) Mozilla firefox
    Preference
    General -> Connection -> Connection Settings ->
    Configure Proxies to Access the Internet
    Only check - Direct connection to the Internet

    3) Privacy -> Cache -> Use up to: 50000 (original) KB of disk space for the cache
    Changed to : 30000 KB

    Re-start Mozilla firefox - situation remained more less the same
    Re-boot PC -> start Mozilla Firefox again - not much improvement.

    Please advise what other measures I can take. TIA

    B.R.
    satimis

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Not sure this would help, but you could try disabling IPV6 like this:

    Either add the line: "alias net-pf-10 off" (without quotes)
    to the end of your /etc/modprobe.conf file, as root.

    or...

    as root, do this:

    # echo "alias net-pf-10 off" >> /etc/modprobe.conf

    Besure to restart your network, or reboot to test this.

    ozar
    oz

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Hi ozar,

    Tks for your advice.

    Not sure this would help, but you could try disabling IPV6 like this:

    Either add the line: "alias net-pf-10 off" (without quotes)
    to the end of your /etc/modprobe.conf file, as root.
    The line is already on /etc/modprobe.conf

    Also having added to /etc/sysctl.conf following line;
    net.ipv4.tcp_default_win_scale = 0

    I'm trying to ascertain whether it is ISP's problem OR the problem of the network setting of the PC.

    # telnet www.google.com 80
    Code:
    Trying 66.102.7.99...
    Connected to www.google.com (66.102.7.99).
    Escape character is '^]'.
    ^]
    Connection closed by foreign host.
    # traceroute www.google.com
    Code:
    traceroute: Warning: www.google.com has multiple addresses; using 66.102.7.147
    traceroute to www.l.google.com (66.102.7.147), 30 hops max, 38 byte packets
     1  203.88.164.1 (203.88.164.1)  18.827 ms  17.280 ms  18.159 ms
     2  202-123-94-73.ihenderson.com (202.123.94.73)  18.119 ms  18.391 ms  17.936 ms
     3  202-123-94-41.ihenderson.com (202.123.94.41)  17.942 ms  17.258 ms  16.728 ms
     4  203.131.241.121 (203.131.241.121)  19.154 ms  19.478 ms  18.684 ms
     5  ge-0-0-0.r01.newthk01.hk.bb.verio.net (203.131.240.92)  19.153 ms  51.244 ms  19.146 ms
     6  p4-1-1-0.r01.tokyjp01.jp.bb.verio.net (129.250.3.197)  97.674 ms  98.693 ms  97.968 ms
         MPLS Label=188624 CoS=5 TTL=1 S=0
     7  ge-7-0-2.r21.tokyjp01.jp.bb.verio.net (129.250.3.181)  87.410 ms  86.109 ms  98.726 ms
         MPLS Label=638624 CoS=5 TTL=1 S=0
     8  p64-2-1-0.r21.sttlwa01.us.bb.verio.net (129.250.4.185)  208.866 ms  208.567 ms  208.121 ms
         MPLS Label=760498 CoS=5 TTL=1 S=0
     9  xe-0-2-0.r20.sttlwa01.us.bb.verio.net (129.250.4.16)  195.201 ms  206.968 ms  252.771 ms
    10  p16-1.sprint.sttlwa01.us.bb.verio.net (129.250.9.62)  285.255 ms p16-0.sprint.sttlwa01.us.bb.verio.net (129.250.8.122)  207.980 ms  206.269 ms
    11  sl-bb22-tac-6-0.sprintlink.net (144.232.9.151)  207.590 ms  207.438 ms  207.629 ms
    12  sl-bb23-tac-15-0.sprintlink.net (144.232.17.182)  208.232 ms  214.497 ms  211.829 ms
    13  sl-bb22-sj-9-0.sprintlink.net (144.232.20.8)  198.286 ms  198.060 ms  198.878 ms
    14  sl-bb21-sj-14-0.sprintlink.net (144.232.3.161)  198.930 ms  197.310 ms  198.042 ms
    15  sl-st20-sj-13-0.sprintlink.net (144.232.9.58)  197.581 ms  198.048 ms  198.258 ms
    traceroute seems slow.

    I also ran following tests to check NIC;

    1)
    # mii-tool -v
    Code:
    eth0: autonegotiation failed, link ok
      product info: vendor 00:00:00, model 0 rev 0
      basic mode:   autonegotiation enabled
      basic status: autonegotiation complete, link ok
      capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
      advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
    This is a 10/100 Mbit, full duplex card. But it is not displayed. Why autonegotiation failed?

    # ethtool eth0
    Code:
    Settings for eth0:
            Supported ports: [ TP MII ]
            Supported link modes:   10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
            Advertised auto-negotiation: Yes
            Speed: 10Mb/s
            Duplex: Half
            Port: MII
            PHYAD: 32
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: d
            Current message level: 0x00000007 (7)
            Link detected: yes
    The speed shown here is 10Mb/s

    # ethtool -S eth0
    Code:
    NIC statistics:
         early_rx: 0
         tx_buf_mapped: 0
         tx_timeouts: 0
         rx_lost_in_ring: 0
    Not much information displayed here.

    # netstat -i
    Code:
    Kernel Interface table
    Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
    eth0       1500   0     7322      0      0      0     7420      0      0      0 BMRU
    lo        16436   0     1752      0      0      0     1752      0      0      0 LRU
    ppp0       1492   0     6908      0      0      0     7006      0      0      0 MOPRU
    Would there be a problem on NIC?

    Any advice?

    TIA

    B.R.
    satimis

  4. #4
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Hi ozar,

    Tks for your advice.

    Not sure this would help, but you could try disabling IPV6 like this:

    Either add the line: "alias net-pf-10 off" (without quotes)
    to the end of your /etc/modprobe.conf file, as root.
    The line is already on /etc/modprobe.conf

    Also having added to /etc/sysctl.conf following line;
    net.ipv4.tcp_default_win_scale = 0

    I'm trying to ascertain whether it is ISP's problem OR the problem of the network setting of the PC.

    # telnet www.google.com 80
    Code:
    Trying 66.102.7.99...
    Connected to www.google.com (66.102.7.99).
    Escape character is '^]'.
    ^]
    Connection closed by foreign host.
    # traceroute www.google.com
    Code:
    traceroute: Warning: www.google.com has multiple addresses; using 66.102.7.147
    traceroute to www.l.google.com (66.102.7.147), 30 hops max, 38 byte packets
     1  203.88.164.1 (203.88.164.1)  18.827 ms  17.280 ms  18.159 ms
     2  202-123-94-73.ihenderson.com (202.123.94.73)  18.119 ms  18.391 ms  17.936 ms
     3  202-123-94-41.ihenderson.com (202.123.94.41)  17.942 ms  17.258 ms  16.728 ms
     4  203.131.241.121 (203.131.241.121)  19.154 ms  19.478 ms  18.684 ms
     5  ge-0-0-0.r01.newthk01.hk.bb.verio.net (203.131.240.92)  19.153 ms  51.244 ms  19.146 ms
     6  p4-1-1-0.r01.tokyjp01.jp.bb.verio.net (129.250.3.197)  97.674 ms  98.693 ms  97.968 ms
         MPLS Label=188624 CoS=5 TTL=1 S=0
     7  ge-7-0-2.r21.tokyjp01.jp.bb.verio.net (129.250.3.181)  87.410 ms  86.109 ms  98.726 ms
         MPLS Label=638624 CoS=5 TTL=1 S=0
     8  p64-2-1-0.r21.sttlwa01.us.bb.verio.net (129.250.4.185)  208.866 ms  208.567 ms  208.121 ms
         MPLS Label=760498 CoS=5 TTL=1 S=0
     9  xe-0-2-0.r20.sttlwa01.us.bb.verio.net (129.250.4.16)  195.201 ms  206.968 ms  252.771 ms
    10  p16-1.sprint.sttlwa01.us.bb.verio.net (129.250.9.62)  285.255 ms p16-0.sprint.sttlwa01.us.bb.verio.net (129.250.8.122)  207.980 ms  206.269 ms
    11  sl-bb22-tac-6-0.sprintlink.net (144.232.9.151)  207.590 ms  207.438 ms  207.629 ms
    12  sl-bb23-tac-15-0.sprintlink.net (144.232.17.182)  208.232 ms  214.497 ms  211.829 ms
    13  sl-bb22-sj-9-0.sprintlink.net (144.232.20.8)  198.286 ms  198.060 ms  198.878 ms
    14  sl-bb21-sj-14-0.sprintlink.net (144.232.3.161)  198.930 ms  197.310 ms  198.042 ms
    15  sl-st20-sj-13-0.sprintlink.net (144.232.9.58)  197.581 ms  198.048 ms  198.258 ms
    traceroute seems slow.

    I also ran following tests to check NIC;

    1)
    # mii-tool -v
    Code:
    eth0: autonegotiation failed, link ok
      product info: vendor 00:00:00, model 0 rev 0
      basic mode:   autonegotiation enabled
      basic status: autonegotiation complete, link ok
      capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
      advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
    This is a 10/100 Mbit, full duplex card. But it is not displayed. Why autonegotiation failed?

    # ethtool eth0
    Code:
    Settings for eth0:
            Supported ports: [ TP MII ]
            Supported link modes:   10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
            Advertised auto-negotiation: Yes
            Speed: 10Mb/s
            Duplex: Half
            Port: MII
            PHYAD: 32
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: d
            Current message level: 0x00000007 (7)
            Link detected: yes
    The speed shown here is 10Mb/s

    # ethtool -S eth0
    Code:
    NIC statistics:
         early_rx: 0
         tx_buf_mapped: 0
         tx_timeouts: 0
         rx_lost_in_ring: 0
    Not much information displayed here.

    # netstat -i
    Code:
    Kernel Interface table
    Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
    eth0       1500   0     7322      0      0      0     7420      0      0      0 BMRU
    lo        16436   0     1752      0      0      0     1752      0      0      0 LRU
    ppp0       1492   0     6908      0      0      0     7006      0      0      0 MOPRU
    Would there be a problem on NIC?

    Any advice?

    TIA

    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •