Find the answer to your Linux question:
Results 1 to 3 of 3
hi i wonder if somebody could help me ????? i have just install redhat 6.2 which i have put on my network. i got three computer on my network. 1. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    1

    Cannot connect to the internet


    hi i wonder if somebody could help me ?????

    i have just install redhat 6.2 which i have put on my network.

    i got three computer on my network.

    1. Linux
    2. Xp_professional
    3. Win Server 2003
    4. Belkin wireless adls router

    All the machine are fine and are pinging each other, all the windows machine can connect to the internet via the router. The router is acting as the gateway : 192.168.24.254.

    I have a problem with the linux box. I am using dhcp and the linux box was assigned the following IP address : 192.168.24.78 ,hostname:vinux. I can ping all the machine and even the router from the linux box or even ping the linux machine from the windows machines. But the problem i am having is when i trying to connect to the internet from the linux box. The error msg :- Bad request

    The following test i have done :-

    ifconfig

    etho Link encap:Ethernet Hwaddrr xxxxxx
    int addr:192.168.24.78 Bcast:192.168.24.255 Mask:255.255.255.0

    lo Link encap:Local Loopback
    int addr:127.0.0.1 Mask:255.0.0.0

    ping -c 4 router

    ping successful

    ping -c 4 google.com

    ping:unknown host google.com


    route

    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.24.0 * 255.255.255.0 U 0 0 0 etho
    127.0.0.0 * 255.0.0.0 U 0 0 0 lo
    default router 0.0.0.0 UG 0 0 0 eth0


    resolv.conf

    domain viksign.com
    namerserver 127.0.0.0
    namerserver 80.255.248.50

    nswitch.conf

    hosts: files dns


    i have tried to use all the resources i could but still i could not make it work. i would be grateful if anyone of you can help me to resolve my problem

    cheers
    vikz

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    I had exactly the same problem a few days ago, it came down to a communication problem between the router and the Linux machine.
    Solution was to reset the network connection, the way my router said to do this was:- unplug router for 15sec then reboot the computer, Could be differant for other routers though so check you kit.
    Mine's worked perfectly since.

    HTH

  3. #3
    Linux User
    Join Date
    Apr 2005
    Location
    Ohio
    Posts
    326
    why does /etc/resolv.conf list a nameserver at a network address ?

    127.0.0.0 is a network address not a valid host address.
    If you are intending to point at the local machine through the loopback address that is 127.0.0.1

    you need to fix or remove that entry from your resolv.conf to start.. then test again
    far...out

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •