Find the answer to your Linux question:
Results 1 to 3 of 3
Hey, Been using Ubuntu 5.10 for a few weeks, I wouldn't say i'm a n00b when it comes to linux, but definitely not a guru. So that sets the stage. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    Force internet gateway - 2 nics


    Hey,

    Been using Ubuntu 5.10 for a few weeks, I wouldn't say i'm a n00b when it comes to linux, but definitely not a guru. So that sets the stage.

    I have my ubuntu box, I have a connection to my eth0 card in my box, that goes to the house router that distributes dhcp and internet. It is on a 255.255.0.0 subnet and distributes 192.168.1.* ip's.

    I have my eth1 nic pulling from my personal router in my house that pushes 255.255.255.0 subnet, with a 192.168.0.* ip convention being distributed by dhcp.

    My eth0 card again is supposed to be my internet and internet gateway card. It works great when it is the only card enabled. When I go in and enable eth1, and go to Connect to Server... and connect to my windows server here in my room, my internet gateway switches from eth0 to eth1. Again, it works fine when I am not connecting to my server.

    I was wondering what I can do to force my box to use eth0 as my default internet gateway...? Independently the connections work great, but together, the eth1 takes over the eth0's internet gateway priorities, which causes me to lose internet access until I disable eth1's card, and reboot.

    Thanks,
    ~Mario

  2. #2
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    So you want to NAT your other boxes behind your Ubuntu? This is what I got.
    I think this malfunction happens when kernel tries to find out which interface to use to connect to internet, and then shuffles its routing table. Maybe you should try to set up a gateway for eth0 or something..

    My routerbox runs great when I give for behind-nat interface 192.168-type address and before-nat fetches its ip via DHCP from ISP. But you seem to have a connection which gives you a C-class (192.168-type) ip. If you can make eth0 to fetch public ip from ISP, you can of course try it.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    I live in a large house with about 15 people. We share a public router, and I have my personal router. I have two nics. One that pulls an IP from the public router, and one from my private router. I want to always have my box look for the internet gateway under the eth0 adapter. That's basically what is going on. I just want to force my box not to try to switch it back and forth.

    Thanks.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •