Find the answer to your Linux question:
Results 1 to 6 of 6
I have recently installed Fedora 4. I'm tring to logon to a share folder on Linux from a XP machine. I can see the folder, and it prompts me for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4

    Cannot Logon to Share Folder


    I have recently installed Fedora 4. I'm tring to logon to a share folder on Linux from a XP machine. I can see the folder, and it prompts me for a username and password but nothing works. I've looked everywhere the resolve this problem with no luck. I also tried to FTP into this server and still no luck.

    Any ideas?

    Thanks

  2. #2
    Just Joined! dothacktsukimoto's Avatar
    Join Date
    Feb 2006
    Posts
    9
    First of all, for security reasons, the Samba server will only allow users to log in to users (unless you override this) that exists at the /etc/passwd file... in other words, your FC4 system must have a Unix user assigned.

    FC4 provides a utility called "system-config-samba", I heavily reccomend to use it, but follow the following:
    1.- Add a Samba User first !!! using "system-config-samba", go to the menu "Preferences -> Samba Users" and fill properly all the requested information.
    2.-Add your share (or delete the other you just created), check the information at "Basic" tab is OK, then go to the "Access" tab and select "Allow acess only for this users" and choose the Samba user you just created at step 1.
    3.-Make sure your firewall allows incoming requests to the SMB service !!!
    4.- Go to a terminal, get root access and type:
    "#/etc/init.d/smb restart"
    or
    "service smb restart"

    That's it !!! Try it ! If you still having trouble, you might need to do some "tweaks" with the Samba server configuration, PM me if you need this.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Thanks for your quick response.

    I followed the steps and I'm still having the same problem. Once I created a new user and a new share file, I can see the server on the XP machine, open it up with no problem, go to open the share file, XP prompts for a password only, the username is greyed out and says "Homie\Guest". I did not create a Guest account, I don't think I did any way..... and any password I use does not work.

    BTW Homie is the name of the Linux Box.

    One more thing,
    Make sure your firewall allows incoming requests to the SMB service
    I'm not sure if I'm setting this correctly. I'm going to :
    System Setting/Security Level and on the Firewall options I only have the following options: (All Unchecked)
    Secure WWW (HTTPS)
    FTP
    Mail (SMTP)
    WWW (HTTP)
    SSH

    And Trusted Services
    eth0
    sit0

    and no other ports.

    And what should be checked on the SE Linux Tab?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! dothacktsukimoto's Avatar
    Join Date
    Feb 2006
    Posts
    9
    Leave SE Linux intact ! In order to allow access to SMB service, type the following at "Other ports" in order to allow access:

    netbios-ns:tcp, netbios-dgm:tcp, netbios-ssn:tcp, microsoft-ds:tcp

    (You can copy-paste this string instead of typing it)

    And to this little "tweak", use system-config-samba" and go to "Preferences -> Server Configuration", make sure your WinXP and Workgroup fields matches, add any description you like, then go to "Security" tab and choose from "Authentication Model" the "User" option, leave "Encrypt Passwords" as "Yes". then at "Guest account" select your Unix account bounded to your created Samba User.

    Become root (using "su -l" using a terminal), do the following:

    # service network restart
    # service smb restart
    # service iptables restart

    Try again with calm ! It's much better to access the resource via IP, this means, if "Homie's" IP is 192.168.1.2, then at your XP machine go to " \\192.168.1.2 "

    If you want to know your local IP at Linux, type this in a console being root:

    # ifconfig | grep "inet addr"

    take note on the address starting with "192.168" ... (Or you can spot your local IP with other tools or widgets like "Network Monitor" at GNOME)

    If it prompts for username and password, provide your "Samba" username you create and the password you assigned, if this don't work, leave the Samba username and type no password, if still asking password then type "Guest" at the username with no password, finally leave the two fields blank ...

    if the problem persists might be something messy with configuration files, PM me so I can mail you specific instructions and ready-to-go configurations and scripts... (This is just if you can't solve this...)

  6. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Here is result of : ifconfig | grep "inet addr

    inet addr:192.168.4.3 Bcast:192.168.4.255 Mask:255.255.255.0
    inet addr:127.0.0.1 Mask:255.0.0.0


    My gate way is 192.168.4.1
    Windows machine: 192.168.4.8
    Homie: 192.168.4.3

    this problems still presist but I really appreciate your help with this problem.

  7. #6
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Also, I still see the shared linux folders and Homie and when I try to logon now it totaly denies access, not even a password promt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •