Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I have configured a simple share between two computer in the same lan, one using FC3 and the other being windows XP home. The thing is i can drop and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342

    SAMBA behaviour


    I have configured a simple share between two computer in the same lan, one using FC3 and the other being windows XP home. The thing is i can drop and copy files on the shared folder withing windows, from any machine, being linux or windows. But when trying to access the shared folder inside my linux box, i get a window that asks me to put a username and password. It says on the window title: 'connect to localhost.localdomain'. What the hell is going on here?

    Here's the parts i modified from smb.conf: (some lines have a ; there, the manuals didn't say i should remove them)

    workgroup = MYGROUP

    ; hosts allow = 192.168.1. 192.168.2. 127. 10.0.0.

    ;[SHARED]
    ;path = /home/punisher/Shared
    ;public = yes
    ;only guest = yes

    Why is it so complicated to achieve something this simple?

  2. #2
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    The semi-colon at the beginning of the line makes that line a comment -- so basically, your entire config is commented out...
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

  3. #3
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342
    That's an interesting point. I am going to try again and see what happens. Thanks man.

    Still, i just removed those semi-colons and i get the same thing. Why does it ask me for a username and password if i am telling specifically to allow those hosts and i have not configured any passwords?

    Check out how i left the smb.conf file.

    workgroup = workgroup
    hosts allow = 10.0.0. // i saw some examples for different networks

    [SHARED]
    path = /home/punisher/Shared
    browseable = yes
    public = yes

    And this is how i type the path on the windows box to get to that share: \\10.0.0.4\SHARED

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Sheds, it is asking for a samba username and password which you'll have to add on the server.

    Check out this howto for steps on setting up a samba server and what to do about the password dialog.
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342
    In the security level, if i change shared instead of user i won't get that annoying window then?

    I'll just read the rest and try it when i get home back from work.

    Thanks man.

  6. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Quote Originally Posted by sheds
    In the security level, if i change shared instead of user i won't get that annoying window then?
    Essentially yes.
    Life is complex, it has a real part and an imaginary part.

  7. #7
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342

    Smile

    Well, thanks for all the help, i now get a different message that says, making the long text short. that i don't have enough permissions to view that share. But at least i got the share to appear on the 'network places' on the Windows machine, so i'll just check it and do the user thing, see what happens. Thank for the help man, that manual was really helpfull.

    Just one thing, what if i want all users in general to just view and browse a share, with no need to have a user defined for it?

  8. #8
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342

    Thumbs up

    Guess what, i followed all instructions, added users, and nothing. Why is it so complicated?

    All i need to do is share a folder, so people can view and browse a shared folder, and that's it. I don't need to add users, but i did anyway, here's the link: http://www.samba.netfirms.com/addusers.htm#adduser

    I am trying this at work too, the last posts were written at home, in both cases, i can view the shared folder but access is denied. I added a user like the above link said, but nothing. Can i like put the folder in a wide open state so any user, without specifying one, can view the files? This user stuff is giving me a headache.

    Plus, it's kinda hard to think when you are watching who's line is it anyway. Jaajaja sorry, just blowing off some steam.

  9. #9
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    A chmod 755 /path_to_share on the samba server should do the trick along with setting security to share rather than user.
    Life is complex, it has a real part and an imaginary part.

  10. #10
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342
    Ok, gonna try it up right away.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •