Find the answer to your Linux question:
Results 1 to 3 of 3
Hello! I run a Linux Mandriva 2005LE edition, and I experience some problems with my network. I am part of a network which connects to the internet through a server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1

    intermittent internet access


    Hello!
    I run a Linux Mandriva 2005LE edition, and I experience some problems with my network. I am part of a network which connects to the internet through a server which shares its connection. The network has static address assignment for each host. The problem is that, from time to time, I suddenly lose my Internet access for good. The typical scenario is: I browse the Internet using Mozilla Firefox, and suddenly the web pages are not loaded anymore by the browser. I try to ping external addresses (e.g. www.linux.org) and also addresses from within my subnet, but I get the same response : Destination Host Unreachable.

    I have done some more research and collected some info on my configuration, I hope this will help in trying to identify the problem.

    * When running lspci | grep Ethernet , I get the following listing:

    01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

    * When running lsmod, I get (put here only the part that interest us) :

    r8169 21100 0

    This would mean that the correct module is loaded for my NIC

    * In the booting process, there are no errors, or at least that's what I think, because for every step of the boot process, the green [OK] appears.

    * ifconfig - a displays:

    Link encap:Ethernet HWaddr <MyHwAddr>
    inet addr:<MyIP> Bcast:<BCastAdd> Mask:<MySubnetMask>
    inet6 addr: <MyInet6Adr> Scope:Link

    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:18373 errors:0 dropped:0 overruns:0 frame:0
    TX packets:672 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1643910 (1.5 Mb) TX bytes:148182 (144.7 Kb)
    Interrupt:10 Base address:0x2000

    The IP and Subnet Mask are the ones provided to me by my ISP. This is a listing obtained from the time the 'Net is up and running(I can post to the forum U know ), but I noticed that, when I run ifconfig after the problem has occured, the errors fields from RX and TX packets are different from zero


    * the /proc/interrupts shows the following(only the part related to the network)
    10: 15216 IO-APIC-edge ohci_hcd, ohci1394, eth0, EMU10K1
    So this should be a signal that there could be an IRQ conflict? EMU10K1 is my sound card module.

    * the /proc/ioports shows the following:

    a000-dfff : PCI Bus #01
    a000-a01f : 0000:01:08.0
    a000-a01f : EMU10K1
    a400-a407 : 0000:01:08.1
    a400-a407 : emu10k1-gp
    a800-a8ff : 0000:01:0b.0
    a800-a8ff : r8169

    * the listing of /etc/sysconfig/network

    NETWORKING=yes
    GATEWAY=GatewayAddr
    GATEWAYDEV=eth0

    * the listing of /etc/sysconfig/network-scripts/ifcfg-eth0

    DEVICE=eth0
    BOOTPROTO=static
    IPADDR=MyIP
    NETMASK=255.255.255.128
    NETWORK=Addr
    BROADCAST=BCastAdd
    ONBOOT=yes
    METRIC=10
    MII_NOT_SUPPORTED=no
    USERCTL=yes
    GATEWAY=GatewayAddr
    TYPE=Ethernet

    The settings are the ones provided to me by my ISP.

    When the problem occurs,I have tried the following in order to restore the network, but without success:

    - /sbin/ifdown
    /sbin/ifup

    - service network restart

    - service shorewall stop
    For a period of time I suspected my firewall of this problem, but when running with shorewall stopped I still get the same problem

    I have noticed that when this problem occurs, if I try to shut down/restart the system, the rebooting process gets stuck when trying to stop the ALSA sound server. From the /proc/interrupts combined with this would get the impression that there is a hardware conflict between the sound card and the NIC. But that is just speculation. If someone could please tell me where are the logs from the shutdown of the machine, I could get more information. I know that dmesg shows the logs for startup, but I don't know how I can list the shutdown logs.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,875
    I think your problem is caused because you're using internet connection sharing of some kind; you're not the PC that's connected to the internet, yet you have used the IP address for the external connection for your computer.

    If you change to an internal IP address, and set the IP address of the PC with the internet connection as your default gateway, then all should work smoothly.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1

    network problems

    i am a new user of linux i am just doing my be i installed mandriva linux 2006 and it gets succesdfully installed but at times there are some zigzag lines in my desktop i do know why my vedio card is 64 mb and many times i cannot able to connect to server tried some times it gets connected but manytimes not can any one advice me how to clear this problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •