Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I'm following the directions in the tutorial on how to get a wireless LAN card to work, but when I try to unpack ndiswrapper I get an error message saying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    18

    Can't unpack ndiswrapper & other issues


    I'm following the directions in the tutorial on how to get a wireless LAN card to work, but when I try to unpack ndiswrapper I get an error message saying it can't make the directory & something about a read only system. I'm using a Knoppix 4.0 CD & the ndiswrapper that came with it wouldn't install either; it gave me an error message about some .inf file missing?! So at this point I've tried ndiswrapper 2 different ways & have no success yet. My wireless card uses the Broadcom 4306B0/2050 chipset so there's no way around not using ndiswrapper. Oh, I'm trying to unpack the latest version ndiswrapper-1.10.tar.gz & have read all the release notes but none of them tell if this is release works with my chipset. So am I running the wrong ndiswrapper release or is there some other issue?

    Issue #2 - Assuming I can get my wireless card to work (eventually) I've read that Knoppix isn't really a good distro for hard drive installation. So should I continue working in Knoppix or just move on to SuSE, Mandriva or some other distro? Bear in mind I want to use kismet, tcpdump & other similar tools.

    Issue #3 - Am I gonna have to get another network card anyway to run kismet? Since the Broadcom chipset requires SO much hack/configuring would I just be better off getting something in the Prism or Aironet chipset, then installing one of the more popular distros on my hard drive & just going forward from there?

    I realize I've asked alot of questions & some of them probably belong in another forum, but any feedback would be greatly appreciated.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Ok, when using the ndiswrapper which came with Knoppix, you'll need more than just an inf file, most cards would come with a sys file or bin file or a rad file along with the inf file. So get all those files together and then try using ndiswrapper.

    When trying to compile ndiswrapper, where have you saved the source code? if it is on a read-only partition, then you'll get that error.

    Now, Knoppix 4 I believe can be easily installed to the hard drive. But there is nothing stopping you from going to SUSE or Mandriva or any of the other distros.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    18
    OK, I found the required drivers (bcmwl5.sys and oem6.inf). As for distros, I'm gonna move on to Mandriva and see where that gets me. As far as trying to compile ndiswrapper I had it saved on my hard drive. Where else would I save it b/c I haven't partitioned the drive as I'm running a CD? Also, how do you tell what version of ndis... works with your kernel? The release notes don't say anything!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    I know you saved it onto your hard drive, but you saved it to a windows partition did you not? If you wanted to compile it, you would have had to copy it from the hard drive to the ramdisk in order for it to compile.
    i.e. cp /mnt/windows/where_ever_you_saved_ndiswrapper_source ~/
    the above command would copy it from your windows drive to the knoppix home directory in the ramdisk, thus enabling you to compile it. Now because you tried to compile it while the source was still on the windows partition, you got that error.

    When compiling from source, it usually doesn't matter which version of ndiswrapper you use as long as the kernel source exists. Now I a gussing on this, but I don't think knoppix includes the source code for the kernel on the disc, so you will have trouble compiling ndiswrapper regardless.

    My suggestion to you is this, try getting the bcmw sys files and inf files, then try with the ndiswrapper which came with knoppix, else get a linux distro installed onto your drive in order to save you some hassle.

    best of luck with whatever you choose.
    Life is complex, it has a real part and an imaginary part.

  6. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    18
    Thanks for the help AlexK. Now I have ndiswrapper compiled and I received a message stating to use iwconfig to set up the network card. However, no I'm either having syntax issues or something else is wrong. I typed in the following two lines exactly as listed:

    iwconfig wlan0 ESSID <my network name>
    iwconfig wlan0 key s:"<my network key>"

    After I entered the ESSID line the prompt continues like its waiting for something else, it didn't give me a new prompt proceed by knoppix... written in blue. After entering the key line it did the same thing and just sat there with the character '>' like its waiting. I gave it over 5 minutes but still no connection.

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    what does iwconfig return on its own?

    also what does this command return:
    Code:
    dmesg | grep 'ndiswrapper'
    Life is complex, it has a real part and an imaginary part.

  8. #7
    Just Joined!
    Join Date
    Mar 2006
    Posts
    18
    The output from the shell is as follows:

    knoppix@0[knoppix]$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    sit0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:off/any
    Mode:Managed Frequency:2.412 GHz Access Point: 00:00:00:00:00:00
    Bit Rate:54 Mb/s Tx-Power:25 dBm
    RTS thr:2347 B Fragment thr:2346 B
    Power Management:off
    Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    knoppix@0[knoppix]$ dmesg | grep 'ndiswrapper'
    ndiswrapper version 1.1rc3 loaded (preempt=yes,smp=yes)
    ndiswrapper: driver oem6 (Broadcom,01/18/2003, 3.10.39.2) loaded
    ndiswrapper: using irq 10
    wlan0: ndiswrapper ethernet device 00:90:4b:51:3f:70 using driver oem6, configuration file 14E4:4320.5.conf
    knoppix@0[knoppix]$


    AlexK, I realize that on the wlan0 the ESSID reads off/any but I tried it with the ESSID broadcast on & still had the same result = NO CONNECTION. I turned the broadcast off again (I always keep it off anyway) once I saw it didn't fix the problem. Now what???

  9. #8
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try this command to see if the card can scan:
    Code:
    iwlist wlan0 scan
    for the purpose of setting up the network, leave the ssid broadcast on. Once you have verified that it works, you can turn it off. Now, you are executing the iwconfig wlan0 xxxx commands as root right?
    Life is complex, it has a real part and an imaginary part.

  10. #9
    Just Joined!
    Join Date
    Mar 2006
    Posts
    18
    The result of the iwlist wlan0 scan command is listed below:


    wlan0 Scan completed :
    Cell 01 - Address: 00:00:00:00:00:00
    ESSID:"my ESSID name"
    Protocol:IEEE 802.11g
    Mode:Managed
    Frequency:2.462 GHz (Channel 11)
    Quality:0/100 Signal level:-31 dBm Noise level:-256 dBm
    Encryption key:on
    Bit Rate:1 Mb/s
    Bit Rate:2 Mb/s
    Bit Rate:5.5 Mb/s
    Bit Rate:11 Mb/s
    Bit Rate:18 Mb/s
    Bit Rate:24 Mb/s
    Bit Rate:36 Mb/s
    Bit Rate:54 Mb/s
    Bit Rate:6 Mb/s
    Bit Rate:9 Mb/s
    Bit Rate:12 Mb/s
    Bit Rate:48 Mb/s
    Extra:bcn_int=100
    Extra:atim=0
    Extra:wpa_ie=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXX

    As far as executing commands in the root I’m 99.9% sure I was there as I went to the root shell, not the regular one I can cut & paste in. Everything I post here I type & copy in the regular shell as I’m unable to copy from the root shell (when I right click with the mouse no menu comes up). I pasted a copy of my shell commands so you can see the output exactly as I see it. Everything is the same except the word root is at the beginning of every line instead of the work knoppix.

    knoppix@0[knoppix]$ iwconfig wlan0 ESSID <(my ESSID name)>
    > iwconfig wlan0 key s:"<my network key>"

    Then it prints out this line immediately below it (I added this line of text)

    iwconfig wlan0 key s:"<part of my key iwlist wlan0 scantherest of my key>"
    > dhcpcd wlan0
    >

    Is my password causing the problem? Bear in mind I use a very robust password (the maximum character limit with spaces, quotations marks, etc). Is the password too big? I find it odd that it prints out part of the pass key, another command (iwlist wlan0 scan) and then the rest of the pass key.

  11. #10
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    are you using wpa encryption or wep encryption? if you are using wpa, you'll need to download a program called wpa_supplicant and configure that before attempting to connect to the wireless network.

    and does Cell 01 really return 00:00:00:00:00:00 for its MAC address, or is that just a typo? Also, there is no need to go into the root terminal of knoppix, you can just go into a normal terminal and su to root. i.e. in a normal terminal, execute this command to become root:
    Code:
    su -
    Life is complex, it has a real part and an imaginary part.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •