Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Riverton, UT, USA

    All right, finally some ifconfig output! And it's telling us by the lack of an "inet addr:" statement for eth0 that you're not getting a network address.
    I'm going to assume that you have a DHCP server, either in the form of a router or your broadband modem if you're connecting directly to it. (You mentioned a hub in the first post; is it really just a hub, or is it a router?) In a terminal, issue the dhclient command:
    # dhclient eth0
    If that is successful, you'll get an address and should be up and running. Otherwise post the output here or Google for keywords that come up.

    Of course, if you're not using DHCP, then you'll have to set the address manually. That's easy to do, but if it still doesn't work after that, it's harder to troubleshoot.
    Stand up and be counted as a Linux user!

  2. #12
    Linux User
    Join Date
    Apr 2005
    Also the contents of etc/network/interfaces would be helpful. It could be a simple misconfiguration in your network settings..

    cat /etc/network/interfaces

    itg-debian:~# cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet dhcp
    auto eth0 tells the system you want the interface to start automatically, the next line tels it to grab an address automatically through dhcp

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts