Find the answer to your Linux question:
Results 1 to 6 of 6
I am trying to connect to a server using a cross over cable. The network stays up for about 20 seconds then changes to inactive. When I activate it again ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    Question Marcus: Status change for active to inactive


    I am trying to connect to a server using a cross over cable. The network stays up for about 20 seconds then changes to inactive. When I activate it again I am able to ping the server and then it changes to inactive again. My laptop is dual boot with XP. I am able to connect to it with XP without any issues but I need to connect to it with the linux. Has anyone ever seen this problem before?

  2. #2
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    Well, are you trying to use DHCP? Probably there is no DHCP-server in the network, so it's not supposed to work. You have to configure static IP:s for both of the computers, for example

    Computer1:
    IP: 192.168.0.1
    Netmask: 255.255.255.0

    Computer2:
    IP: 192.168.0.2
    Netmask: 255.255.255.0

    I think connecting straight computer to computer is a dumb solution. Years ago I used to connect a couple of computers with crossover cable, and it was REALLY hard to make it work. Prefer using hub or switch or something, it eases things up a lot.

    With linux, you can make network configuring with ifconfig. If your network interface is eth0 and you want the ip 192.168.0.1 for your linux, you type
    Code:
    ifconfig eth0 192.168.0.1
    If your netmask is not right, set it for example to 255.255.255.0. Netmasks should be same at the both computers.
    Code:
    ifconfig eth0 netmask 255.255.255.0
    Note this is only temporary configuring. You have to make a config file for your linux to make it set the network up at boot.

  3. #3
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3
    No I am using static IPs and subnet. I know my IP configuration is correct since I am able to ping the host. But the problem is that it only stays up for about 20 seconds.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Apr 2005
    Location
    Ohio
    Posts
    326
    Sounds like it could be an issue with autonegotiation on the Ethernet cards..They may not be properly negotiating their speed and duplex settings. At least it's something you can check.

    If you do an ifconfig and see collisions then the cards have not negotiated properly and are operating in half-duplex mode. The only time the cards should be in half duplex is when they are plugged into a hub. a switch is full duplex as is a direct connection between two pc's with a crossover cable.

    It may work with colissions for a small amount of data, like the pings that work for you.. but then the interface goes down afterwards..

    you can use ethtool to Force the BOTH ethernet cards to 100MB full Duplex when using the crossover cable, and that may resolve your issue.

    ethtool -s eth0 speed 100 duplex full autoneg off

    Let us know..
    far...out

  6. #5
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    Smile It worked

    Much much appreciated. After installing the ethtool it work perfectly.

    Thanks Farslayer

  7. #6
    Linux User
    Join Date
    Apr 2005
    Location
    Ohio
    Posts
    326
    Glad you got it working
    far...out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •