Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I have just installed Redhat EL 4 on my new T43 and configured a wireless connection using an IPW2200 device. My access point is an Apple Airport. My IBook ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    4

    Unhappy Activate wireless connection using WAP


    Hi,

    I have just installed Redhat EL 4 on my new T43 and configured a wireless connection using an IPW2200 device. My access point is an Apple Airport. My IBook receives a wireless connection successfully. On my T43 it works fine as long as WAP Personal wireless security is disabled. But if I enable it, it fails to get an IP address. When I try to set the password using "iwconfig eth1 key mypassword", I get an error: error for wireless request "Set Encode" (8B2A): invalid argument "mypassword".
    I installed the wpa_supplicant module but to no avail.

    I am new to LINUX and struggling to get this wireless connection to work. Any help would be greatly appreciated.

    Thanks

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    what kind of encryption are you using WEP or WPA? And when you did iwconfig eth1 key xxxxxxxxxx, were the xxxxxxxxxx in string format or in hexadecimal format?
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    4
    I am using WPA - PKIS encryption. The password is in ASCII format. I have also tried to convert it to HEX but didnt change anything.
    When using HEX, I prefixed the password with 0x

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by RegisSh
    I installed the wpa_supplicant module but to no avail.
    Why can't you use wpasupplicant (with wpapassphrase)?

    I have an IPW2200 card as well and I connect with wpasupplicant no problemo.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    4
    I installed wpa_supplicant and added the ENABLED=0 in the /etc/wpa_supplicant.conf. But is it sufficient? Is there anything that must be started?

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Well,
    are you sure your wpa_supplicant.conf file is setup correctly and did you run this command:
    Code:
    wpa_supplicant -c<path to wpa_supplicant.conf> -i<interface_name> -D<driver name>
    Life is complex, it has a real part and an imaginary part.

  8. #7
    Just Joined!
    Join Date
    May 2006
    Posts
    4
    I first tried to use the ascii password in the wpa_supplicant.conf, then generated the encrypted one using wpa_password, but none worked.
    I ran "wpa_supplicant -c/etc/wpa_supplicant.conf -ieth1 -w" but it wouldnt start propertly.
    What I dont get is that I must first start the interface eth1 before launching the wpa_supplicant. But how can this interface instantiate a connection without the wpa password?
    Anyway, I was running out of time and couldnt bother spending anymore time. I changed to Fedora Core 5 and now everything is ok (except StarOffice that I cannot install but that's another challenge that's now driving me nuts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •