Find the answer to your Linux question:
Results 1 to 5 of 5
I have a DSL modem connected to a Belkin 4 port cable/DSL Router (Model F5D5231-4) and two computers connected to the router, one running on Windows XP Home and my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    Router issue (Belkin non wireless) on Lispire 5.0


    I have a DSL modem connected to a Belkin 4 port cable/DSL Router (Model F5D5231-4) and two computers connected to the router, one running on Windows XP Home and my Linspire 5.0 box. The Windows computer installed the router software and connected immediately, but my Linspire box will not connect through the router, even though this computer connects to the web flawlessly when I just plug it to the DSL modem directly I've tried the following:

    1) Restarted Linspire 5.0 (This system seems to detect ans install everything on restart, so it seemed like a good option)

    2) Restarted the router

    3) Typed 192.168.1.254 on the address bar (That's the Modem IP Address)
    I contacted Belkin's tech support and this is the answer I got:
    Quote:
    We understand that you are unable to connect to the Internet, from your Linux computer. On the computer, check if you have an IP address in the range of 192.168.2.x. If not assign a static IP address in the range of the router, that is 192.168.2.x (x=2to200).

    4) Went to Settings > Control center > Network > Network settings and Profiles (Logged in as Root). I checked and it shows "Configuration Mode DHCP".

    5) Went into my Router (through the Windows XP computer) and checked the "Connection Configuration: PPPoE.
    It also shows the following:
    Modem IP address: 192.168.1.254
    Subnet mask: 255.255.255.0
    DHCP Start Address: 192.168.1.1
    DHCP End Address: 192.168.1.253
    VPI: 8
    VCI: 35
    Protocol: PPPoE
    Static IP Address: 0.0.0.0
    WAN IP Address: 65.2.124.9

    6) I opened a terminal and typed "ifconfig". This is what it tells me: (not that I know what any of it means...)
    eth0
    Link encap:Ethernet HWaddr 00:0D:88:3B:2D:07
    inet addr:192.168.1.254 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:150 error:0 dropped:0 overruns:0 frame:0 TX packets:150 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:41868 (40.8 KiB)
    Interrupt:12 Base Address:0x6000

    6) I changed the interface from the default "eth0 [D-Link System Inc RTL8139 Ethernet (rev-10)]" to "eth1 [VIA Technologies, Inc. VT6102 [Rhine-II](rev-7]". It didn't work neither, so I changed back to the default.

    None of the above made any difference. The Linspire 5.0 computer does not seem to recognize a web connection through the Belkin router.
    Any suggestions will be greatly appreciated!!!

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Modem IP address: 192.168.1.254
    This is fine... but i notice:

    inet addr:192.168.1.254 Bcast:192.168.1.255 Mask:255.255.255.0
    in the output of the ifconfig command.... the modem and Computer cant have the same IP address... else it wont work! You need to set the default gateway of the PC to what the router's IP is. Try setting this to something different, that may well help
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    I may be getting everything wrong, I really am a green newbie at this... I hope I am not posting the wrong info!!!! Anyway, just in case, here's what I read in the Modem, in the Widoze box and in the Linspire Box:

    The modem displays the following:
    Connection Information
    IP Address : 72.153.74.34
    IP Gateway :65.14.252.2
    Primary DNS: 205.152.144.23 dns.mia.bellsouth.net
    Secondary DNS: 205.152.132.23 dns.msy.bellsouth.net
    Local Network
    Modem IP Address: 192.168.1.254

    Windoze “ipconfig”displays the following:
    IP Address 192.168.2.9
    Subnet mask: 255.255.255.0
    Default Gateway: 192.168.2.1

    Linspire “ifconfig” displays the following:
    Link encap:Ethernet HWaddr 00:0D:88:3B:2D:07
    inet6 addr: fe80::20d:88ff:fe3b:2d07/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1

    I can ping the network card (I didn't know how to do that until now!!) on the Linspire box, but cannot ping the Router.

    I'll be away until Sunday, thank you so very much for your help!!!!!

  4. #4
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    According to the windows machine the routers address is 192.168.2.1
    With my router typing http://192.168.2.1 in a browser takes me to the routers administration settings.
    The router deals with connecting to the ISP. For some reason the linspire machine is not getting a proper 192.x address from the router.
    Is the indicator light on at both ends of the cable, card and router?
    Have you ever had another flavour of linux running on this machine?

    If your linspire disk has livecd ability (like the one I'm using right now) consider booting it up this way for testing. Something seems messed up on your installed system.

    Here's something you could try, use at your own risk.
    Go to the router settings and assign a fixed address to the linspire machines ethernet card. 192.168.2.100 would be fine. Assign it to the cards MAC addresss 00:0D:88:3B:2D:07
    Now on the linspire machine
    Launch>settings>Control Center>network>network settings & profiles>tcp/ip tab
    Under configuration mode choose static
    IP address : 192.168.2.100
    subnet : 255.255.255.0
    gateway : 192.168.2.1
    Under DNS servers enter simply: 192.168.2.1
    Make sure there are checkmarks in "enable this interface" and "this is my primary interface"
    Make sure the firewall is not set to "closed"
    Click on "apply changes"

    Now try the webbrowser. If it works it's still not really ideal but gives us something to work with. Note this is all based on my setup using ADSL through a d-link. Belkins may be more difficult.
    WARNING: I may be telling you more than I know !

  5. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    Well, I'm close to giving up by now: I've tried all of the above and nothing happens. I'll be away from my computers for a week, I'll start again next Monday, hopefully I'll feel less confused by then...
    Thanks for all the suggestions, and I'll keep you posted when I come back...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •