Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, On our mail server, all of a sudden this morning, it is really slow when sending emails to (via) it and connecting via SSH. I did a packet capture ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    46

    Pause after TCP 3-way handshake


    Hi,

    On our mail server, all of a sudden this morning, it is really slow when sending emails to (via) it and connecting via SSH.

    I did a packet capture while sending an email to it and noticed the following:
    After the TCP 3-way hanshake finishes, there is a 12 second pause before the next packet.

    So when I send an email, the three TCP connection initation packets go through. Then there are NO packets at all. 12 seconds later the rest of the SMTP connect goes through (really quickly).

    The same happens when connecting via SSH a 12 second period with no packets after 3-way handshake).

    Like I said, this happend all of a sudden this morning.

    We keep tight logs of who has access (as well as restrictions) and no one has accessed it.

    I tried restarting the network interface, the SMTP server, and all other server daemons on the computer. This did not change anything.

    We do not want to reboot the server, but if that is the only thing that will fix it, then...

    I would also like to point out that when we connect via POP, the connection goes at full speed (no pause).

    Thanks.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    46
    The problem is solved.

    It turns out that it was a DNS issue. I am now using our other ISP's DNS servers and everything is working at full speed again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •