Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    slow network transfers when linux initiates

    When I transfer files between two xp machines I get a speed of about 44MB/s nomatter whether I am pushing or pulling or which machine is initiating the transfer. This I consider to be a slow transfer, as it should go up to 125MB/s on a GigE network, but for the moment I am satisfied with it.

    When I dualboot one of my xp macines into rhel4u2 and initiate a transfer then the speed is rediculously slow. Only about 6MB/s. Again it is the same for pushing and pulling. The odd part about this is that if I initiate the transfer from my xp machine, then the speed is relatively okay, at about 27MB/s both ways.

    I have tried changing linux driver parameters for the intel GigE nic and linux buffer settings, as I suspect the linux software to be responsible for the slow transfer speeds, but so far without any luck.

    Could anyone in here please point me in direction to what kind of parameters I should change, in order for the linux machine to be able to do transfers at speeds equivalent to the xp machines.

  2. #2
    My findings so far have led me to believe that the culprit of my misfortune is to be found in the driver setting InterruptThrottleRate=0. This is what boosts xp network throughput, but apparently that option is not being effective in linux. I know that the tcp/ip packet size and buffers differ in some way from linux to xp machines and that that is causing delays 75% of the time, but how to ensure that they are identical I have no clue. Anybody in here with an onboard intel 1000e nic that is able to do 10+MB/s transfers between linux and xp machines when the linux machine initiate the transfer, then I would very much appreciate how your config files have been setup.

    Sincerely Kasper

  3. #3
    I have made a tcpdump and it shows that mss is 1460 when xp initiates the transfer and that the ip addresses of both machines are present, but that mss is 1440 when linux initiates the transfer and that only one ip address is present in the list, the other is one from a dynamic dns company. My isp provides me with 3 dynamic ip addresses, as I cannot get more than one fixed. XP seems to handle this OK, but linux does not. I will try to attach my router to the switch and disconnect my internet line from the switch to see if this solves the problem. I am also changing the SO_RCVBUF and SO_SNDBUF values from 8192 to 8760 to accomodate for the change from 1440 to 1460 in linux.

    Any help is still very appreciated.

  4. $spacer_open
  5. #4
    This is what I have got in my tcpdump logfile:
    (1460) OK
    (1448) BAD
    (1440) BAD
    (1264) BAD

    I need to change some linux parameters so that the bad values are changes to the good one. So far I have managed to make some changes that makes 1440 into 1448 and 1264, but I have not succeeded in making 1440 or 1448 into 1460.
    Please advise me how to do that.

  6. #5
    Changing the MTU size in ifcfg-eth0 file to 1460 to see if this helps

  7. #6
    I've almost given up now. The MTU size does not change in linux in the tcpdump logfile. It should show up as 1460 and the word mss should also show up, but it doesn't. Maybe I should try with 1500 or 1600. That seems to be my last option before I give up and abandon linux.

  8. #7
    Upgraded the kernel to support web100. Seing if this will tune my system to work. Also trying to change the two windows registry settings that control the window size and buffer size.

  9. #8
    I have run the web100 java applet and it shows the following differences in settings between my two machines:
    web100 setting______xp_____linux

    Could anobody in here provide assistance? I need to change the settings so that they are identical. Whether it be xp or linux does not matter as long as they are able to talk to each other with the same packet size. I think that it would be easiest to change the linux parameter from 1448 to 1460. The xp regedit setting might not work, as I think it could be hardcoded into the software.
    Please help. Anyone!

  10. #9
    added support for iptables in the kernel that I just upgraded to.
    Now iptables work fine, but the mss size is still 1448 even though ifconfig and iptables report it to be 1500. Something is very wrong about linux. Trying to change the mss size from 1460 to 1448 in xp to see if this will boost network throughput. If so, then all I need to do is change the mss size in rhel4u2 or fc5 and then I should be alright to go. Please help in provide some clues as to how one changes the mss value in linux as the command issued to iptables does not seem to work. i.e. it produces an error message.

  11. #10
    Ive finally made a breakthrough. I have run tcpdump on one of my xp machines and it shows that there is NO packet loss when transferring files between xp machines. I now KNOW for a fact that the slow transfers are due to packet losses between linux and xp. All I need to do now is eliminate the packetlosses and speed should be up to normal.

    C:\>windump -i 2 -w out.txt
    windump: listening on \Device\NPF_{Intel(R) PRO/1000 CT Network Connection (Microsoft's Packet Scheduler)}

    311998 packets captured
    312050 packets received by filter
    0 packets dropped by kernel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts