Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I have a DWL-520+ wifi nic (H/W Ver.: A3 F/W Ver.: 2.03). I'm trying to make it work under Debian with kernel 2.6.16.14. I managed to compile ndiswrapper just ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    3

    Problem with ndiswrapper and DWL-520+


    Hi,

    I have a DWL-520+ wifi nic (H/W Ver.: A3 F/W Ver.: 2.03).
    I'm trying to make it work under Debian with kernel 2.6.16.14.

    I managed to compile ndiswrapper just fine (I'm using ndiswrapper 1.16).
    The ndiswrapper suggested to use the driver that came with the CD. I tried doing that and it just won't work.
    When doing:

    Code:
    ndiswrapper -l
    I get:
    Code:
    Installed drivers:
    gplus   invalid driver!
    Did anyone ever manage to get this kind of card with these specific revision to work ok?

    thanks in advance,
    metis.

  2. #2
    Linux User Giles's Avatar
    Join Date
    May 2005
    Location
    Gloucestershire and Cambridge, UK
    Posts
    283
    I did try to install the G520+* a while ago, so some things may be similar: there are three driver files, I believe, on the CD that comes with the card: gplus.bin plus.inf and gplus.sys (this is from memory, so correct me if I'm wrong). I believe that the file you need is the .inf, but that you need to have the others in the same directory to get ndiswrapper to see it as a valid driver. (and then, if gplus.inf doesn't work, at least they're conveniently placed for you to be able to try each file...).

    HTH
    Giles

    *D-Link seem to construct their names so that they can cause as much confusion as possible...
    "Our greatest fear is not that we are powerless. Our greatest fear is Microsoft"
    Registered linux user #391027

  3. #3
    Linux Newbie
    Join Date
    Sep 2004
    Location
    Aberdeen, Scotland
    Posts
    204
    Giles is correct - complete nightmare so i would double check which chipset you have http://ndiswrapper.sourceforge.net/m...p/Installation - Install Windows driver section and compare with the pciid on list http://ndiswrapper.sourceforge.net/m...dex.php/List#D I have the D-Link AirPlus G+ DWL-G520+ with acx111 chipset and it works fine with ndsiwrapper.
    Elive,kanotix-mini,pclinuxos super gamer,xp, sidux

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •