Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Hi, Thank you for your helpful reply. I was having the problem of "eth0 ifup: could not get a valid interface name" appearing at boot and not being able to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2004
    Location
    New York City
    Posts
    1

    ifup eth0 activates my card, but not at boot


    Hi,

    Thank you for your helpful reply. I was having the problem of "eth0 ifup: could not get a valid interface name" appearing at boot and not being able to access the network.

    However, when I issued the command "ifup eth0" at the shell prompt, my network was activated.

    Can anyone tell me what I must do to have the networkd activated at boot so I do not have to issue this command each time?

    Thanks,
    Jim

  2. #12
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    add a line
    alias eth0 3c59x

    to /etc/modules.conf so that the driver gets loaded at startup.

  3. #13
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    Quote Originally Posted by vacajohn
    after installing RH 8 on an old HP PII machine, everything works except the net card. I've read everthing in the forums and tried different configs and removing and re-installing 3 different cards but cannot activate any of them.....
    the OS sees each card after install and detection.
    i turned off Plug n Play in BIOS after reading that it could create problem
    but that didn't help at all.
    the card in there now is a 3com 3C905b PCI
    i tried an etherlink III ISA card and it wouldn't activate either
    i have it set for dhcp
    i'm not sure what IRQ to set it at, though I tried using 3 to no avail
    the driver module seems to be in the right place as well

    please help if you can,

    John A.

    I run into the same problem. Just finished to install a fresh FC1 (standard kernel 2.4) on old PC (Pentium90) but with a 3COM EtherlinkIII marked as 3c508B on the board.

    Same as you, after installing there was no eth0 recognised, only the loopback.
    I run the modprobe 3c59x but got some errors. But then I tried the "modeprobe 3c509" and this did the trick. "Magically" this solved the issue and now the card got the IP from my local DHCP and now I am writing to you while putty is connected to the P90 via SSH

    Now I need to see how to fix this permanently so that it will stay there also after rebooting
    Following is the list of similar drivers I got on the system.

    [root@localhost root]# /sbin/modprobe -l 3c*
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/3c59x.o
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/3c509.o
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/pcmcia/3c589_cs.o
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/pcmcia/3c574_cs.o
    /lib/modules/2.4.22-1.2115.nptl/unsupported/drivers/net/3c515.o
    /lib/modules/2.4.22-1.2115.nptl/unsupported/drivers/net/3c507.o
    /lib/modules/2.4.22-1.2115.nptl/unsupported/drivers/net/3c505.o
    /lib/modules/2.4.22-1.2115.nptl/unsupported/drivers/net/3c503.o
    /lib/modules/2.4.22-1.2115.nptl/unsupported/drivers/net/3c501.o
    /lib/modules/2.4.22-1.2115.nptl/unsupported/drivers/net/tokenring/3c359.o


    THX
    CIPO

  4. $spacer_open
    $spacer_close
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •