Find the answer to your Linux question:
Results 1 to 7 of 7
I've made a couple of mounts from a other machine Xandros Desktop OS V2.0 Deluxe to my Firewall (Trustix Secure Linux). It works perfectly, but when I'm a normal user ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193

    mounts


    I've made a couple of mounts from a other machine
    Xandros Desktop OS V2.0 Deluxe to my Firewall (Trustix Secure Linux).

    It works perfectly, but when I'm a normal user I can't write something to my Xandros machine. Permission Denied.

    Everyone has write permissions, read permissions. Even with a WinXp client I can write to these partitions.

    But I when I mount these networkshares I only can write with Root permissions. I don't want that.

    I've made the mountings on this way

    mount -o username=akr,password=dumb //192.168.0.1/SHARED /mnt/network/SHARED

    It works perfect with root permissions, but not with user permissions. How to change that?
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    One way is to adjust the permissions on that mount using the uid, gid, fmask or dmask mount options. See the smbmount manpage for more info.

    Another way is to share them to the Linux machine using NFS instead. In my mind, that's preferable.

  3. #3
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    I've used this in my fstab.

    //192.168.0.1/APPS /mnt/network/APPS smbfs defaults,umask=0777,gid=100 0 0

    But still no write permission. Also here an piece of my smb.conf from my machine where the shares are.

    [SHARED]
    public=yes
    browseable=yes
    path=/disks/C
    writable=yes
    write list=akr,root,@users
    max connections=0
    available=yes
    valid users=akr,nobody,root,@users
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Indeed - umask=0777 will remove all permissions for everyone. The umask is the inverted permission bits, so umask=0000 is probably more likely what you want if you want everyone to have full access.

  5. #5
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    I even tried 0000, but still no permissions to write.

    I even used with my shares:

    create mask = 0775
    create directory = 0775

    Even this won't work. Only my Windows machines can use these shares. If you think you've got everything. I always had some problems for Windows Machines, but these machines will work. Now my 3 other Linux machines won't work with these shares. How strange. All the machines got the same problem?
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Now when I think about it, I don't think that smbmount uses the umask option. I think it uses fmask and dmask instead. Try passing "fmask=0000,dmask=0000" and see if that helps.

    What is in smb.conf should not matter for this issue. It only affects the server.

  7. #7
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    I've used this rite now and it works perfectly:

    mount //192.168.0.1/APPS /mnt/network/APPS -o uid=root,rw,dmask=0777,fmask=0777

    Thnx for it Dolda
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •